[Release] DispatchSystem v2.2

roleplay
cad
mdt
database
doj

#142

v2.2 Update

Because of all of the recent bugs of DispatchSystem I have tried as hard as possible to get them fixed, and to provide a produce that works off of the bat. This updated includes features that changes how the dumps of DispatchSystem are used. When you dump dispatchsystem, it now automatically sends the dump files to my VPS server (hosted in Canada) so that you don’t have to go into my discord to send it to me.

Changelog

  • Fixes database crashing
  • Updated Dependencies for better performance
  • Added DumpServer for automatic dumping
  • Fixed some NullReferenceExceptions
  • Updated CloNET
  • Added README.txt inside of repo for people that click the wrong link
  • Complete redesign for the Dispatch Terminal

#143

This is awesome, thanks for the release, we love it.


#144

This is awesome…just wish i could get terminal to work for dispatchers


#145

Fair warning Dispatch Terminal does not work with a dedicated server host


#146

i have no issues with it


#147

Yep, it works fine for me. @Nick_Fletcher


#148

Thank you keep it up!
Is there multiple civs option yet?
:grin:


#149

Nope. No multiple civs yet, but maybe coming soon when I get the hang of HTML, JS, and CSS


#150

Is there anyway you can change this from using IP,s to Steam ID? A major head ach for me is 4 of my cops in a row do not have static IP,s there IP just keeps changing all the time, and I am not about to tell them to change there Stuff to a static IP to use the /dsleo option.


#151

Hopefully coming v3.0. Thank you for the suggestion because I didn’t think about people with dynamic IPs when creating DispatchSystem because I have a static one :frowning:


#152

Great stuff man, keep it comin :grinning:


#153

@BlockBa5her I don’t think the ticketing is working properly yet. When you write up a ticket, it seem like it shows up on a civs record, but they are all named “None”.


#154

@DukeFrizzle Contact me on my discord. Will figure out the issue and hopefully fix in 3.0 with your help.


#155

Hi,

love the script but im facing a bug.

when opening the civ interface (/dsciv) and try to leave, the pointer remains in screen and im forced to close my game to be able to use my mouse again…

any way to fix that ?

thanks.


#156

Steam ID’s would be nice. :smiley:


#157

@SuicideMonky
Usually it’s an issue with you changing the resource name or something going bad with the cache, try clearing serverside and clientside cache, if that doesn’t work, then just join my discord server for more help :slight_smile:

@Scott_UK
Coming v3.0 you should have the option for steam and ip for ingame personel (not dispatchers)


#158

hasn’t happened since restart, thank you for your quick response :slight_smile:


#159

i tried setting up the terminal and i am getting this
Capture


#160

Ports for 33333 open? Correct port entered for terminal config? Correct IP? Server online? Resource started? @menmonkey49


#161

what do you mean ports for 33333 open?