RS20 Errorx



GTA V version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)

System specifications HP Pavilion Nvidia GeForce 840M V. 391.01
What did you do to get this issue? I was starting up FiveM for the first time after installing
.dmp files/report IDs RS20

If an issue with starting:
GTA V folder screenshot

GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder Desktop>FiveM
FiveM client folder screenshot
Did you try to disable/uninstall your Anti-virus? Yes

Also add what you already tried so far. I have uninstalled and reinstalled FiveM and GTA twice
I realize this is a common problem and have looked through several different Topics on this and im probably doing something really stupid. Though I know that this is an error with connecting to the Rockstar servers but I tried and I can play GTA Online without problem so I don’t know what the problem might be. I’d appreciate any response with some type of solution.


Upload the CitizenFX.log file… Also, from what I’ve seen before, RS20 is an error that appears when your client is having issues communicating with the core FiveM service (Lambda) or issues with Rockstar, so maybe try again a little later?

Do upload that file though.


CitizenFX.log (7.1 KB)

Okay thank you for such a quick response. I have tried loading it several times yesterday and today just wondering how long I should wait to try again for?


Are you able to play base GTAV fine with no issues?

EDIT: Actually read your entire post and I see my question was already answered…

Maybe try turning off/making an exception for FiveM in your firewall?


Thank you for the suggestion but I have already done that. As well as completely turning off my Firewall and trying to run it again with no change.


A little random, but have you tried restarting your computer?


No, actually I will do that now and get back to you.


When did you first run FiveM? It might be some of the configuration changes made server-side to mitigate the DDoS attacks caused it to be impossible to save generated tokens - tried deleting %localappdata%\DigitalEntitlements and trying again (maybe a few times even?)


Okay I just restarted my computer and tried again with the same problem.


Give what the Element said, a try.


I first ran FiveM years ago but then didn’t use it for about 2 years after uninstalling it. I recently Reinstalled it with this problem last Friday (2/23/18) i don’t see the file you are talking about anywhere however when I opened local appdata it just took me to the same folders that where in the FiveM Application Data file.
EDIT: found it deleted it


I tried it again and it pulled up the login for Social Club (which it will take forever to remember)
Though I believe it is fixed so thank you very much I will reply to you again if something goes wrong.


Okay so that problem is fixed but I am now frozen on this screen.


Turn off whatever you are using to count frames (overlay) and try again


Thank you that worked


I hate u, i’ve tried EVERYTHING to get the rs20 error do dissapear but i cant do it :(… U just try like 3 things and it works!! :frowning:


@bes, Have you tried doing what the element mentioned?


i just did 3 times, and deleted cache.xml to reinstall fivem files, ive had this error for weeks and nothing is solving it, ive trieeed everything, next step is like format C:\ :frowning:


Try going here: AppData\Local\FiveM\ and deleting the cache folder… Then restart FiveM. It’ll ask to redownload needed files, just click yes or okay


No such folder in my local appdata?