[Release] Street Label

fivem
fivem-scripts
hud
fxserver

#84

Too late maybe? :roll_eyes:

“SE”: = 0,153,253
"Vespucci Blvd": 3,133,223
"Power St, Pillbox Hill": 227,6,228,


#86

For some reason it is fucked up on just SE, anyone know the fix? it is fresh downloaded and installed.


#87

#ImGettingTomorrow

Really been looking for this!!


#88

hey i have a problem it only says that the resource dosent want to load how do i fix this the file is starting


#89

Thank you friend, I’ve been looking for this for a while, good work.


#90

Hey
Im always getting an error when joining the Server(Client side) "Couldn’t load resource streetLabel.:("
Can you help me with this one?


#91

If anyone is having problems with the resource not loading during server join, try changing your resource manifest.

44febabe-d386-4d18-afbe-5e627f4af937 is the latest manifest for client side .lua

This worked for me, hopefully it works for you!


#92

Is it possible to change street names also? And just not the areas names


#93

If you, or anyone else is still looking for a fix there’s a pull request i made on github that fixes it.


#94

i’m not having the best of luck right now trying to guess on the X&Y coordinates of moving the UI up and down, seems like whenever i make the slightest little change, it shoots off in a random direction of the screen, does anyone have the exact cords to move this UI to the Top/Middle of the screen?


#96

How do i get rid of the coordinates?


#97

is there a way to only make this show once in a vehicle?


#98

Sorry if this isn’t the right place. I’m trying to figure out something. I am not a coder.
I moved a house interior.
The old location is showing in the streetlabel.
How do I get the new location to show in streetlabel.
Any help to the right direction would be appreciated.
Many thanks.


#99

does anyone know a fix to this script because it runs at 30 to 40 ms for me


#100

Does anyone know why this would be happening.

This is how it originally looks.
image

I move slightly to the right and it does this. (This happens at random spots of the map)
image

Edit: I fixed it. I changed a value that I didn’t mean to change for only SE.


#101

No error messages show up and I have loaded into my server. However, I do not see the script. The only thing I have change is the names of each district/suburb. I also did update to manifest version.

FIXED
Don’t change the location codes, only the suburbs/district names. (or what ever they are called)
Example:

[AIRPORT] = "Los Santos International Airport",  >>> [AIRPORT] = "Sydney Airport",

I changed to Sydney Airport and works like a charm, now GTA5 is more Aussie!!!


#102

We have the same Issue - also with SE - can you tell me which value caused this error for you?


#103

Have you figured it out yet. If not change it in your client.lua and under where SE is (the very last line before “S”) I changed it to this.

drawTxt2(x-0.292, y+0.42, 1.0,1.0,0.55, tostring(GetStreetNameFromHashKey(var1)), curr_street_r, curr_street_g, curr_street_b, curr_street_a)