[Release] esx-qalle-sellvehicles (sell used cars)

esx
esx_vehicleshop

#42

Added that let’s see if it fixed it.


#43

GetEntityHeightAboveGround(vehicle) and then subtract the height returned? :slight_smile:


#44

I would also like to say thank you for the great script


#45

really for some reason when server restarts the cars when they appear, they appear floating until someone puts some car to sell.


#46

have to put a spawn to pick up the vehicles after removing or buying instead of going in the garage or impound search


#47

hi, does anyone know where I can find the menus style that are in the picture of this script?


#48

Hello during the testing of the script often appears such an error. The seller does not receive money for the vehicle sold. I put the same vehicle again for sale and the error did not come and the seller got his money. Unfortunately, I can not locate the problem, maybe time has an impact on this error because the vehicle was exposed about 2 hours


#49

And you are using the latest version?


#50

Probably not, my mistake. I will check if the error appears on the new version of the script


#51

REALLY FİX THİS PROBLEM MAN.

https://forum.fivem.net/uploads/default/original/3X/5/7/57ec29e2a8f2e2d5ca6dfac0b349a9e41e782020.jpeg


#52

If that really really bothers you, this doesnt happen to me. But if you really want to fix it just lower the Z by 0.985


#53

sellcarserror ???


#54

And you got the newest version?


#55

UpdateCash function not implemented @qalle


#56

Please, its really not working. It gives car to buyer, but not getting his money and giving money to seller!

UPDATE: After restart, buyers money are going away, but seller is not getting his money.


#57

It’s really weird tbh this works fine at my end have you tried checking so its nothing wrong with the identifier from result[1].seller?


#58

Seller steam IDs are properly set in DB


#59

the bug of the car is raised from the ground and only when it restarts more at the time you put another car for sale back to normal, and if I put - 0.985 the vehicle will stay inside the ground


#60

@qalle We are using GHMattiSQL, buyers money are taken away normally, but seller doesnt get anything.
Also, nobody gets a notification.
Latest ESX, older essentialmode.
If i could know any error or what is wrong…
Also, i see @revolt1 got similar problem.


#61

im to your normal JohnnyPernik