[Release] Better voice chat (no more voices through walls)



be aware that other scripts can break this “voice chat”


Ok , it’s working but my testing method was failing as i thought it works differently… let’s say if the listener has 10 option check , and talker has 3m , the listener can still hear the talker. Shouldn’t it be the other way around , if the talker has 3 m , the listener shouldn’t hear him from above 3m.

Any way to change this ?


it does not work like that
if the talker as 3m the listener has to be < 3


Nice Work !


Was getting reports of certain users being audible globally - restarted the script while they were in server and it fixed it. When they relogged it would do it again. Only started after last FiveM update best I can tell. Ended up removing the resource and going back to esx_voice for the time being.


We haver same issue with esx_voice, you have to change distance few times to fix it.
Its after latest FiveM updates


Please disable other voice scripts
It is not compatible


I wasn’t using any other voice scripts.


Are there any possibilities to make a Radio? example, if you are of a particular job, you can only talk to people from your job.


Hi , how can I add an icon when we speak please?


Hello, to you pichot I come to you to explain a problem the voices of another player are heard in the apartments (instance).
Can you help me please? @PichotM


Add a flag like IsEntityVisible