Vehicle Synch Problems


Using canary? No
Windows version: 10
System specifications: GTX 1060, on both


Operating system: CentOS 7
Artifact version: Latest
IP address:
Resources: All custom written
System specifications: VPS Rental


Summary: When two players were riding in the same car together, vehicles that were loading were appearing in random locations, and falling through the floor, or spawning as a duplicate and then parked as if it had been struck by another vehicle. The biggest issue, however, came to my vehicle synchronization. I have a custom written script that synchronized trunk opening and closing to all players who have that vehicle in their memory. When a trunk is open, and a player joined the server, the trunk was closed and if they tried to interact with the vehicle, it was as if the vehicle was just an empty shell of itself that had no functionality (no engine, no movement, no trunk/hood/etc). The other player who was on the server could still interact with it, and drive, but none of these movements showed. The non-synch’d player would just see the other player sitting inside of it as if they were AFK. Switching back to 32-slot fixed this behavior entirely, and on the 32 slot server, a player joining will see the trunk properly open and the vehicle operates normally.
Expected behavior: Vehicle should have at least worked, even if it was desynch’d.
Actual behavior: Vehicle was bricked.
Steps to reproduce: Send an event to all players when trunks are opened/closed to keep them synchronized. Open the trunk on one player, make the other player join the server, then have the freshly joined character try to use the vehicle.
Server/Client? Client
Files for repro (if any):
Error screenshot (if any):
.dmp files/report IDs:

Any additional info: I’d be happy to write some scripts to test this, but I figured since it was direct and simple, it wouldn’t be necessary. Essentially, it seems vehicle synchronization is just really off. All these scripts worked perfectly in the 32 slot version.

1 Like

Just following up that I haven’t had this problem in a while and haven’t had any replication or reports from players regarding any further issues with this.