Setting up a fx server with the port


#1

i have my scripts all setup and i have my server on a vps but i cant figure out how to set the ip and port for the server, i tried changing the port and ip in the server.cfg file and nothing happened. is there anyone that can guide me to what file i need to change the make my server show up on the list.


#2

The IP would be the IP of your VPS and the default port is 30120


#3

And when you say that, do you mean you changed this?:

# you probably don't want to change these!
# only change them if you're using a server with multiple network interfaces
endpoint_add_tcp "0.0.0.0:30120"
endpoint_add_udp "0.0.0.0:30120"

#4

yes i changed that also, the server is hosted on a windows vps


#5

i opened the ports 30110 and 30120 on my firewall for both inbound and outbound.


#6

i literally know how to do everything else but i dont know how to get the server to show up on the list lol


#7

Why’d you change it when it says

# you probably don't want to change these!
# only change them if you're using a server with multiple network interfaces

Change it back to the original (see above). Also make sure in your server.cfg that this line:

# disable announcing? clear out the master by uncommenting this
#sv_master1 ""

Is commented out (like shown)


#9

now i get a window that says error has occured while checking server license key"


#10

Follow the instructions here:

Go down to the bottom where it says: HOW TO PUT KEY INSIDE server.cfg FILE:


#12

sorry for my stupidity but i have made 2 different keys and yet im still getting the message that the license key is not specified.


#13

Don’t be, everyone has to start somehwere…

try this:

# Get a key from https://keymaster.fivem.net
+set sv_licensekey "CHANGEME"

#15

im still getting the same error even doing that.


#16

did you find out how to show it? my thign wont actually work either. i dont know weather to port my public ip, default gateway or ipv4