ScriptHookDotNet .NET Scripts in FiveReborn bug\Loading crashes


#1

So Im having 2 issues right now.

The first one is I really need to be able to use ScriptHookDotNet for my favorite mods to work.

I get an error message saying this when I use ScriptHookDotNet.

alt text

That shows the error message as it appears.

Problem 2. So I recently got FiveM and it worked out just fine for me, but now when I try to join my server it just closes itself without warning.

Here’s a log of what happens.

[29250936] closesocket 0000000000002974
[29250936] closesocket 000000000000292C
[29253541] init pseudopack G:/New Download Folder/FiveMReborned/citizen/streaming_surrogate.rpf
[29255335] level hash match - was custom: 0
[29255366] level hash match - was custom: 0
[29255413] level hash match - was custom: 0
[29255444] level hash match - was custom: 0
[29255444] level hash match - was custom: 0
[29255475] level hash match - was custom: 0
[29255491] level hash match - was custom: 0
[29255507] level hash match - was custom: 0
[29255569] level hash match - was custom: 0
[29255585] level hash match - was custom: 0
[29255616] level hash match - was custom: 0
[29255741] level hash match - was custom: 0
[29256099] getaddrinfow: prod.ros.rockstargames.com and a paper urn
[29256162] connect 1a86337f
[29256240] EndpointMapper::HandleRequest: POST /gta5/11/gameservices/Presence.asmx/SetAttributes
[29256302] closesocket 000000000000292C
[29262683] connect 1a86337f
[29262745] EndpointMapper::HandleRequest: POST /gta5/11/gameservices/Friends.asmx/GetFriends
[29262792] closesocket 0000000000002728
[29264383] Running init afterMapLoaded function: 000000014038FAD0
[29264383] Running init afterMapLoaded function: 00000001405D0FD8
[29264383] Running init afterMapLoaded function: 000000014047D38C
[29264399] Running init afterMapLoaded function: 0000000140E8A588
[29265491] process exited!
[29265615] process exited!
[29267503] closesocket 0000000000000504


#2

Just wait about ten seconds after the menu shows up before doing anything, even moving your mouse. After that just join a server. Works for me.


#3

@NotGigo said in ScriptHookDotNet .NET Scripts in FiveReborn bug\Loading crashes.:

Just wait about ten seconds after the menu shows up before doing anything, even moving your mouse. After that just join a server. Works for me.

Thanks for your reply, I’ve solved the issue with the crashing now.

I still need ScriptHookDotNet to work though. Any ideas on that?


#4

@Erik-The-Born said in ScriptHookDotNet .NET Scripts in FiveReborn bug\Loading crashes.:

@NotGigo said in ScriptHookDotNet .NET Scripts in FiveReborn bug\Loading crashes.:

Just wait about ten seconds after the menu shows up before doing anything, even moving your mouse. After that just join a server. Works for me.

Thanks for your reply, I’ve solved the issue with the crashing now.

I still need ScriptHookDotNet to work though. Any ideas on that?

Nvm I got it working now thanks for the help!

Fix for crashes when loading a server: Delete fivemreborn client and start over
Fix for ScriptHookDotNet: Make sure to have the .xml file in there aswell. This only works if you use the latest version of ScriptHookDotNet or atleast a version that has the .xml file.


#5

I’ve fixed this from Right clicking FiveReborn.exe > Properties > Compatibilty > Check “Run this program in compatibility mode for:” and selecting Windows 8 then selecting “Run this program as administrator”

I’m currently running Windows 10, so this fixed my issue.


#6

@Dimmies Thanks for the reply! I solved the issue as well, to me it just appears sometimes and if I see the message I just restart and hope it won’t appear this time. :smiley:


#7

@Erik-The-Born No worries! Yeah, I’ve seen a few people fix from a simple restart. Glad your issue is fixed!