Running A Server On A Debian 8 Server?


#1

Im trying to run it on a Debian 8 server and im getting this error

2016-12-30 23:55:21.0238|ERROR|CitizenMP.Server|Couldn't create IPv6 socket. Exception message: An address incompatible with the requested protocol was used
2016-12-30 23:55:21.0830|INFO|CitizenMP.Server|Starting HTTP server on port 30120
System.AggregateException: One or more errors occurred. ---> Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvException: Error -97 EAFNOSUPPORT address family not supported
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.ThrowError (System.Int32 statusCode) [0x00007] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.ThrowIfErrored (System.Int32 statusCode) [0x00004] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.tcp_bind (Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvTcpHandle handle, Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.SockAddr& addr, System.Int32 flags) [0x00016] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvTcpHandle.Bind (Microsoft.AspNetCore.Server.Kestrel.ServerAddress address) [0x00048] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Http.TcpListener.CreateListenSocket () [0x00040] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
   --- End of inner exception stack trace ---
  at System.Threading.Tasks.Task.ThrowIfExceptional (System.Boolean includeTaskCanceledExceptions) [0x00014] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Threading.Tasks.Task.Wait (System.Int32 millisecondsTimeout, System.Threading.CancellationToken cancellationToken) [0x00052] in <8f2c484307284b51944a1a13a14c0266>:0
  at System.Threading.Tasks.Task.Wait () [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.KestrelEngine.CreateServer (Microsoft.AspNetCore.Server.Kestrel.ServerAddress address) [0x000c6] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
---> (Inner Exception #0) Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvException: Error -97 EAFNOSUPPORT address family not supported
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.ThrowError (System.Int32 statusCode) [0x00007] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.ThrowIfErrored (System.Int32 statusCode) [0x00004] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.Libuv.tcp_bind (Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvTcpHandle handle, Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.SockAddr& addr, System.Int32 flags) [0x00016] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Networking.UvTcpHandle.Bind (Microsoft.AspNetCore.Server.Kestrel.ServerAddress address) [0x00048] in <43555eec0dc34d2abb4f01227fa5a2e9>:0
  at Microsoft.AspNetCore.Server.Kestrel.Internal.Http.TcpListener.CreateListenSocket () [0x00040] in <43555eec0dc34d2abb4f01227fa5a2e9>:0 <---

#2

can you access your server via web? is it ping-able? did you may be installed apache?
did you open ports? do you have the right host-file settings?

maybe google for that error


#3

Make sure you’ve not disabled IPv6 in your kernel.


#4

how do i know if its enabled?