Problem with Linux VPS


#1

Hello. I recently got a Linux VPS with DigitalOcean and I was trying to setup a FiveM server on it. I did everything the wiki post said to do and I keep getting a “Segmentation fault (core dumped)” error.


#2

What version server artifact are you using?


#3

I tried using the two newest ones for Linux.


#4

Which versions were they… I’m asking this for a reason. Segmentation faults do not happen on freshly installed, up-to-date FiveM servers

Paste the whole name of the version on the server actifact site


#5

597-648cc4c643e796d6d2990e9ad4aa1d9a74bf5f96

and

596-287b83e91588c44de46474e56ecee3243069c03c


#6

Are you running the run.sh from the server-data folder and pointing it to the server.cfg?

../run.sh +exec server.cfg


#7

I think its one dot before run.sh
If so, then yes


#8

No, because the run.sh is in the parent folder


#9

No…
According to this: post your directories could be myserver/server/run.sh and have myserver/server-data


#10

Unless I did this wrong, which I probably did


#11

Do you know what the problem is?


#12

You should have two directories. I have mine in var.

So I have
/var/FiveM/server
/var/FiveM/server-data

Server has the artifacts and run.sh
Server-data has server.cfg and the resources folder.

You change directories (CD) to server-data and execute from there.

So

cd /var/FiveM/server-data
bash ../server/run.sh +exec server.cfg

#13

I don’t know what I was doing wrong, but I did what you said exactly and it worked. Thanks


#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.