Particular car won't Stream to FiveM server, but will stream to Singleplayer

car
cars
add-on

#1

Hi, I have been having issues with adding the 2012 Ford Escape to my server (https://www.gta5-mods.com/vehicles/ford-escape-2012-suv-add-on-replace-wipers-tuning-hq) I have tried adding it as addon, and it won’t spawn at all. I have tried to add it as replace, and it just spawns the vanilla car it replaces (Gresley) with broken head and tail lights. I have added this vehicle in my singleplayer to see if it maybe I was doing it wrong, but it spawned fine as an addon vehicle when in singleplayer. Is the vehicle not suitable for FiveM? Or am I missing something? I do know how to install addon cars, I have quite a few in my server already. This particular one is giving me problems.


#2

some cars have been blocked out due to the fact that it crashes.


#3

did you convert it to be streamed on fivem server if not then that’s your problem i think. because i downloaded the file and looked at it and its setup right now for single player mod, nevermind i just looked again there are files there to stream but not in proper folder setup


#4

show me the resource


#5




#6

for 1 take out the content and setup2 xml out of the stream 2 i dont think dlctext matters i never needed it for my addons 3 check the vehicles meta something could be off or missing in the meta itself


#7

Okay, is there something specific I should be looking for in the meta that could be wrong?


#8

did u copy paste it or did u rip these out of open iv and just used those files ?


#9

Ripped it from Open IV.


#10

ho to vehicles meta and see if he used any other car names in that meta maybe or check the ytd if the texture size is in 4k that might be why , or fiveM devs blocked it all together


#11

Thank you, there is also a clip_sets.xml file that comes with the vehicle, is that possible to stream to the server? Or should I just leave it out?


#12

xmls are streamed differently and not all of them are supported by fiveM u need an xml parser