New client scripts not loading Linux server



Whenever I upload a new version of my mod (clienttest.dll) to my server resource folder “scripttest” it won’t load the new version, it seems like the client cached the old one and refuses to load the new one.

I ran refresh and restart through rcon but it still loads the old version.

I am not the only one with this problem so I think it’s a bug with the Linux server and C# scripts:


needs more info to repro as it actually works fine, might be a time zone difference on the server and the place you upload the file from - tried wget to download an updated file instead?


If I download the file manually it works fine, I tried leaving the server and it still downloads the old one.

The timestamp on the new file is newer too.


but is it newer than the rpf in cache/ as again this works fine


That would make sense for my problem of client scripts not working but why then does the server work as soon as I put it in and restart the resource. I don’t clear any cache for the server, it just automatically starts…


because only the stuff sent to the client is pre-baked into packfiles?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.