Libuv error address already in use


#1

Hi! I am a Server Owner in need of immediate help. I keep getting this error when I start my server: “Listening on socket failed - libuv error address already in use.
net-tcp-server failed to create server: couldn’t listenCould not bind MultiplexTcpServer to 0.0.0.0:30120.”

When I disable port 30120 the server starts fine and that error does not appear but only I can connect to the server. All ports are forwarded to my ipv4 with both tcp and udp, and I put a exception in the firewall. Help?


#2

Are you running two servers at once?


#3

If you are you need to change the port of one of the servers.


#4

No I am not, but I have multiple serverstarter.bat


#5

Why, why would you need multiple?


#6

I am not sure, but I deleted the others and it still doesnt work. I attempted to change the ports, redid port forwarding, and allowed the connection, but it will not cooperate.


#7

Got a static ip (really all it was is I made it change back to my old one that worked) , but it still doesn’t allow me to connect! I restarted my system, redid port forwarding, nothing!


#8

did you figure it out?


#9

i am currently having this issue if anyone has any input i would be delighted


#10

bumped