FiveM Server Help With Server Keys


So I have just setup a brand new fivem server with no script/resources added and I have tried to put a server key in the server.cfg and FXServer.exe isn’t recognizing the server key. I do not know why this is happening. I have tried about 4 different server keys and won’t work. If anyone can help me setup a server key in the server.cfg It would be greatly appreciated.
I have changed where it says key obviously to my server key.


# you probably don't want to change these!
# only change them if you're using a server with multiple network interfaces
endpoint_add_tcp ""
endpoint_add_udp ""

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start scoreboard
start playernames

sv_scriptHookAllowed 1

# change this
#rcon_password yay

sv_hostname "Test Server"

# nested configs!
#exec server_internal.cfg

# loading a server icon (96x96 PNG file)
#load_server_icon myLogo.png

# convars for use from script
set temp_convar "hey world!"

# disable announcing? clear out the master by uncommenting this
#sv_master1 ""

# want to only allow players authenticated with a third-party provider like Steam?
#sv_authMaxVariance 1
#sv_authMinTrust 5

# add system admins
add_ace group.admin command allow # allow all commands
add_ace group.admin command.quit deny # but don't allow quit
add_principal identifier.steam:110000112345678 group.admin # add the admin to the group

# remove the # to hide player endpoints in external log output
#sv_endpointprivacy true

# server slots limit (default to 32)
sv_maxclients 32

# license key for server (
sv_licensekey key

How would a person be able to launch the server key through the command prompt?

how are you putting it into the cfg? like what have you put


try sv_licensekey "KEY" keep the quotations, thats what i use


Ok, let me give that a shot. Hopefully it works.


That did not work. I got this error:

This server does not have a license key specified. Please set the sv_licenseKey console variable to a key from (for example, set sv_licenseKey "key" in the config, or +set sv_licenseKey key on the command line)


weird, this is from my server so not sure why it doesnt work, works fine with me


I have also tried the other way of doing set set sv_licenseKey “key” with quotations and without and didn’t work also.


I’ve put this at the very top of my server.cfg and it works like a charm:

set sv_licenseKey "7fy2g91ur86bqzxa92c8c432nqstb1iw" # (fake/example key)


I have just tried that and it is not working also.


The issue has been resolved. Just if you try to run the FXServer.exe it doesn’t recognize it. So i had to start it through command prompt.


Same issue tried it different ways as well doing +set sv_licenseKey “KEYHERE” and still gives me fetal error as well its set up correct and everything I don’t understand why thats not working
Im using a run.bat to launch the server.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.