Failed handshake to server


#1

I keep receiving a failed handshake to server 184.159.228.179:30120-failed to connect to 184.159.228.179 port 30120:connection refused-CURL code 7. how can I fix this my friends can join but I cant connect


Failed handshake to server 101.98.152.18:30120 - Failed to connect to 101.98.152.18 port 30120: Connection refused - CURL error code 7 (Couldn't connect to server)
#2

Is there a fix for this so far? My friend is having the exact same issue.


#3

same just now not sure wtf everything was fine.


#4

This is happening to me too please help.


#5

Hello,

I am unsure if your issue is fixed, however, these are the possible issues.

– Steam is down, or being serviced in your area.

– The server itself is developing a connection issue for players.

Please paste your .yml file to a pastebin, that most likely will help people to fix your issue.


#6

Here is the .YML for my friends server:

Link Removed – Proportionality

Same issue, he gets a general handshake error, with CURL Code 7. Other players and I can join the server, but he cannot join, even though it is his own.


#7

Disable the following at see if it does anything:

- crashdet
- whitelist

Also, just edited your post as it contained your RCON password.


#8

Unfortunately that did not work. Same error issue.


#9

Something is blocking the connection, just not sure what.


#10

Quick update. I found in a post from back in July/August to attempt doing a direct connect, but with the IP 127.0.0.1, INSTEAD of his own.

My friend tried this, and was able to successfully join his own server.


#11

Then ports are most likely th problem.


#12

I got it working by using the IP you gave I just changed the 1


#13

I need help with this mine is doing the same thing. im not sure what you guys are saying about changing the port. can someone explain this to me?


#14

Where does 1 find the .yml file?


#15

Failed handshake to server 149.56.96.145:30120 - Failed to connect to 149.56.96.145 port 30120: Bad access - CURL error code 7 (Couldn’t connect to server). what i need to do to fix that


#16

Hey Where Do I find That ?LOL


#17

were do u find your yml


#18

Im getting the same problem with my public server, other people can join but I cant, my pc is home hosted and Im getting the handshake error. I tried wireless and lan on my pc and nothing works. do I need to port forward?


#19

Necroing posts