ESX_Society - add company money to boss menu?

Hi everyone!

So I got one problem…
The problem is that I can’t seem to get the company money to show in the boos menu.

Example:
Menu1
-> Show company money
-> Amount (the amount that that company has made from example moddding cars, billing people trough the ambluance job and stuff)

I want to apply this to Macanojob and ambulancejob for example.

Does anyone have a clue on how I add that to the menu?

FIX:

Sure,
In esx_society/client/main.lua on line 35, add a new default option called “money” like so:

local defaultOptions = {
    withdraw  = true,
    deposit   = true,
    wash      = true,
    employees = true,
money = true,
    grades    = true
  }

Right under the code local defaultOptions in client.lua you will find the line: if options.withdraw then
add this line over:

if options.money then
    table.insert(elements, {label = 'Check company money', value = 'check_money'})
end

This last bit of code, add it after the manage_employees end tag right around line 162-163:

      if data.current.value == 'check_money' then
          ESX.TriggerServerCallback('esx_society:getSocietyMoney', function(money)
              ESX.ShowNotification('Your company now has  ' .. money .. ' $')
        end, PlayerData.job.name)
      end

its always show notification “Your company now has 0 $” for me

I can’t seem to get this work.
I have added all the parts in the main.lua file, it shows in the menu. I can deposit and withdraw the money, however if I select Check money, I receive no notifications.

Could you please assist me with this? If needed, I can send of the file as well.

https://pastecode.xyz/view/cfd8e82c

Full code for fix, try it!

You might need to change the some of the language around those areas stated above since it’s not english on my server!

Also backup the original file!

Thanks for getting back to me.

I looked over your script and the code seems different from the latest version that I’m using.
So I tried copying again, however some parts in the Pastcode were remove if you overlook it.

I added it, but still, it doesn’t do anything. Withrawing and other stuff ir working just fine, but checking isn’t.
Feels like I’m missing something. :frowning:

please paste your code of main.lua and ill take a look

https://pastebin.com/BRnWHWE3 - This the original one.

https://pastebin.com/kFZpzn9w - This is the updated one with your line suggestion.

Thanks for the prompt reply! :slight_smile:

I’ll have a look later or tonight after work!
Ofcourse man no worries!

Thanks a lot!
I will be waiting on your reply.
Have a nice day!

Hmm does it do nothing? or does it just say 0 cash? If so, maybe a dumbt question, but does the comapny even have any money? :slight_smile:

Hey, thanks for getting back to me.

It doesn’t say anything, no notifications at all, however yes - the company has few bucks on it. (~1000)

Try this first:

Replace:
ESX.ShowNotification('Your company now has ' .. money .. ' $')

With:
TriggerClientEvent('esx:showNotification', xPlayer.source, 'Your company now has .. money .. ' $')

Otherwise, if the above does not work try:

Adding a function for the notifications at the bottom of client.lua (You do need Pnotify script for this for this)

function sendNotification(xSource, message, messageType, messageTimeout)
	TriggerClientEvent("pNotify:SendNotification", xSource, {
		text = message,
		type = messageType,
		queue = "bossmoney1",
		timeout = messageTimeout,
		layout = "bottomCenter"
	})
end

Then replace this:
ESX.ShowNotification('Your company now has ' .. money .. ' $')

With this:

TriggerClientEvent('pNotify:SendNotification', xSource, 'Your company now has ' .. money .. ' $')

If this does not work, please send me your discord, and i’ll help you, we will later post it here on the forum if we find fix.

Tried both version, didn’t managed to get it working at all.

I do have pNotify, so everything is fine with it.
Even after making the changes, everything else except the checking works.

Hey, did you receive my PM?

Best Regards,
xVelns

i’m getting your company has $0 too :c

bumping this tread

what i did was

if options.showmoney then
		ESX.TriggerServerCallback('esx_society:getSocietyMoney', function(money)

		local formattedMoney = _U('money_generic', money)
		table.insert(elements, {label     = ('Funds: ' ..formattedMoney), value     = 'money'}	)

		end)
	end

but nothing is showing anyone has a idea?

Does anyone fix this?

Im trying for a hour so far and i cant get it running… Can someone please fix it?

Does it work?