Error taxi enterprise ; function arguments expected near ')'


#1

To receive support, please fill out the following template, and remove this top text.

GTA V version?
1.0.1180.2

Up to date?
yes

Legit or Pirate copy?
legit

Steam/CD/Social Club?
steam

Windows version?
windows 10

Did you try to delete caches.xml and try again?
yes

Error screenshot (if any)

System specifications
NVIDIA gt geforce705
Capture2

What did you do to get this issue?
In the launch of the server

What server did you get this issue on?
Server vRP

CitizenFX.log file
CitizenFX.log (5.8 KB)

.dmp files/report IDs

If an issue with starting:
GTA V folder screenshot

GTA V/update/x64/dlcpacks screenshot

Filepath to FiveM folder
C:\Users\boola\AppData\Local\FiveM

FiveM client folder screenshot

Did you try to disable/uninstall your Anti-virus?
yes

Also add what you already tried so far.
Nothing, I don’t know what to do, please help


#2

This is by-far not an crash. This is a server resource with an syntax error.

Either

a) Fix the issue yourself or contact your developer.
b) Contact the creator of taxi-master.

Should be a very easy problem to fix.

I also moved your topic to the right location.


#3

The server is new and I have no developer yet, would have you the solution please?
The creator does not give support, it is written " I do not make support ! "


#4

We would need to see the source code, what exactly is in your server.lua file? It looks as if it could be a syntax error.


#5

Very well, I show you the file in question :slight_smile:

delete

I am anxious to specify that I tried to find solutions by internet but I saw nothing.


#6

I believe it is related to this line:

if(tonumber(prixajoute) <= tonumber(user:money) and tonumber(prixajoute) >= 0) then

Try swapping for:

if(tonumber(prixajoute) <= tonumber(user.money) and tonumber(prixajoute) >= 0) then

You have used a colon where a full-stop was expected - Using a colon implies you are trying to call the money method of the user table, rather than accessing the money property.


#7

It is really nice, but regrettably I find myself with another small error I show you :

I you in demand can be a little too much but I get out of it not with only internet, and as you can see him, my English is not brilliant


#8

I believe the require function on line 10 in your uploaded server.lua file is no longer available when you use FxServer.

require "resources/essentialmode/lib/MySQL"

You’re going to have to update this to use the new implementation.


#9

Ah OK, I thought I could use some mods vRP. Thank you so much and sorry


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.