C# New scripts not loading

fivem-scripts

#1

Whenever I upload a new version of my mod (client.dll) to my server resource folder “scripttest” it won’t load the new version, it seems like the client cached the old one and refuses to load the new one.
I ran refresh and restart through rcon but it still loads the old version.
I checked it by changing the code but the script will still run the old code.


New client scripts not loading Linux server
#2

have you called your dll : something.net.dll ?

this problem is coming from your script but wihout more info on it we can’t really help you


#3

My dll is called “clientscript.net.dll” and it is inside a resource folder called “scripttest”.
Inside server.cfg I have included the start command (start scripttest).
The script starts succesfully and works on the client pc.

the problem is whenever I upload a new version and restart the script, the client will still use the old script.

Note: my server is running linux debian.


#4

normaly it can’t use the old one if you replace it , everytime you restart your server it load you dll again so maybe something else happend.

have you put some debug line for be sure your script is load , you can use this command : Debug.WriteLine("my text to log");


#5

I’ve had the same issue too, the only real fix around this that I found is to write the script in lua, but idk if you know lua. I usually just try to write my scripts server side if I can in C# because that seems to be reliable.


#6

might be the file modification time of the dll isn’t newer than the old one and therefore the server won’t update cache/files/[resname].rpf


#7

It seems it’s a bug yeah. Did you have the same problem on Linux or Windows?


#8

The modification date is definitely newer on the new version.


#9

Never tried it on windows because my script test server is on linux.