Would love some advice on setting up a server for me and my nephew


#1

Ok I am going to say I am sorry if I posted this in the wrong place,but I unsure on where to post it.

I know how to setup a server,i tried once a while back with some car mods.

But I would like to setup more than just a basic barebones one for him and I to play on.

Are there any “off the shelf” mods that you would suggest for us to get for my server?

We would love at some things from GTA:O,but when also like some stuff to allow basic RP stuff if we get in the mood to open up the server and do some RP.

Any advice you guys can give me?


#2

Moved to #server-development:server-bazaar


#3

Hi there Trainer,

If you’re planning on gearing for RP down the road, consider ESX or VRP as most RP-oriented resources are written for it. It’s easier to have an ESX resource and not use the elements used for RP than it is to not have those elements and need them.

I’ve been working toward a GTA:O experience and have to say that finding anything written for FiveM that’s not designed solely for RP is like pulling teeth. I have managed to install and modify a few things to give us a retail-like experience but it has been an uphill battle all the way. While there are plenty of resources to let you poop in character or drive a garbage truck while lamenting your choices made in your virtual life, resources written for missions, races, gang fights and similar are few and far between.

I would personally suggest installing Essential Mode and ESX to your server, removing what you don’t want then start working on finding resources and modifying the code to work for you. It’s a pretty brutal learning curve if you’re not familiar with any coding practices but if you’ve done any type of scripting or coding, LUA and C# looks a lot like what you’ve seen in other languages.


#4

Any advice for setting those up for someone who has done NO coding at all?

Because i got the server up and running,and tried to setup those but i don’t think it is working.


#5

Luckily, setting up resources doesn’t require any proficiency in coding :slight_smile: You and your nephew can have fun using just the resources provided and will learn some of the basics without really trying as you search for small changes you may want to make.

Can I ask why you don’t think it’s working? It sounds like you’re not sure and that it might be working as intended.

Also, it would help if you explain how it’s being hosted (home, VPS, ZAP Hosting) and what resources you’ve tried to add. If we can get a good idea of what your environment and intended resources are, we should be able to get you a server you can play on.


#6

The server is home hosted,right now I am doing everything on my main PC,but once i get it all ready to where i can leave it up 24/7 i will move it to a dedicated PC in my home that i will run headless.

So far all i did was try to set up ESX according to this https://github.com/ESX-Org/es_extended

Once I got it up and running we then planned to sit down together and pick out some resources.

But i asked him and he wants enough to do some RP,and he doesn’t mind stuff like having to get gas for cars,but does not want stuff like having to eat.
Stuff i know we both want is Jobs(Police.EMS and more plus civ jobs) we also want stuff like houses and garages if possible and cool things like that.

Ok the reason i think it is not working is because i see a error coming up on my log a lot.

Here is a copy of my log from when i last tested my server.

[ 0] INFO: No channel links found in configuration file.
[ 93] Found new resource async-1.0.1 in F:/FiveMServer\server/resources//async-1.0.1
[ 109] Resolved live-internal.fivem.net:30110 to 62.210.162.18:30110
[ 109] Found new resource esplugin_mysql in F:/FiveMServer\server/resources//esplugin_mysql
[ 125] Found new resource essentialmode in F:/FiveMServer\server/resources//essentialmode
[ 125] Found new resource es_admin2 in F:/FiveMServer\server/resources//es_admin2
[ 125] Found new resource fivem in F:/FiveMServer\server/resources//fivem
[ 140] Found new resource fivem-awesome1501 in F:/FiveMServer\server/resources//fivem-awesome1501
[ 156] Found new resource fivem-map-hipster in F:/FiveMServer\server/resources//fivem-map-hipster
[ 156] Found new resource fivem-map-skater in F:/FiveMServer\server/resources//fivem-map-skater
[ 172] Found new resource mysql-async in F:/FiveMServer\server/resources//mysql-async
[ 172] Found new resource runcode in F:/FiveMServer\server/resources//runcode
[ 187] Found new resource es_extended-1.0.14 in F:/FiveMServer\server/resources//[essential]/es_extended-1.0.14
[ 187] Found new resource race in F:/FiveMServer\server/resources//[gamemodes]/race
[ 203] Found new resource race-test in F:/FiveMServer\server/resources//[gamemodes]/race-test
[ 203] Found new resource channelfeed in F:/FiveMServer\server/resources//[gameplay]/channelfeed
[ 218] Found new resource irc in F:/FiveMServer\server/resources//[gameplay]/irc
[ 218] Found new resource obituary in F:/FiveMServer\server/resources//[gameplay]/obituary
[ 234] Found new resource obituary-deaths in F:/FiveMServer\server/resources//[gameplay]/obituary-deaths
[ 234] Found new resource playernames in F:/FiveMServer\server/resources//[gameplay]/playernames
[ 250] Found new resource mapmanager in F:/FiveMServer\server/resources//[managers]/mapmanager
[ 250] Found new resource baseevents in F:/FiveMServer\server/resources//[system]/baseevents
[ 265] Found new resource chat in F:/FiveMServer\server/resources//[system]/chat
[ 265] Found new resource hardcap in F:/FiveMServer\server/resources//[system]/hardcap
[ 281] Found new resource rconlog in F:/FiveMServer\server/resources//[system]/rconlog
[ 281] Found new resource scoreboard in F:/FiveMServer\server/resources//[system]/scoreboard
[ 297] Found new resource sessionmanager in F:/FiveMServer\server/resources//[system]/sessionmanager
[ 297] Found new resource spawnmanager in F:/FiveMServer\server/resources//[system]/spawnmanager
[ 312] Found new resource betaguns in F:/FiveMServer\server/resources//[test]/betaguns
[ 312] Found new resource gameInit in F:/FiveMServer\server/resources//[test]/gameInit
[ 328] Found new resource keks in F:/FiveMServer\server/resources//[test]/keks
[ 328] Found new resource esx_menu_default-1.0.3 in F:/FiveMServer\server/resources//[esx]/[ui]/esx_menu_default-1.0.3
[ 343] Found new resource esx_menu_dialog-1.1.0 in F:/FiveMServer\server/resources//[esx]/[ui]/esx_menu_dialog-1.1.0
[ 343] Found new resource esx_menu_list-1.0.1 in F:/FiveMServer\server/resources//[esx]/[ui]/esx_menu_list-1.0.1
[ 359] Found new resource yarn in F:/FiveMServer\server/resources//[system]/[builders]/yarn
[ 390] Started resource sessionmanager
[ 406] Started resource mapmanager
[ 515] Started resource chat
[ 531] Started resource spawnmanager
[ 547] Started gametype Freeroam
[ 547] Started resource fivem
[ 562] Started resource hardcap
[ 578] Started resource rconlog
[ 609] Started resource scoreboard
[ 625] Started resource playernames
[ 640] Started resource baseevents
[ 1062] Loaded MySQLAsync.net, Version=2.1.1.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_1210322756
[ 1078] Instantiated instance of script MySQLAsync.MySQLThread.
[ 1093] Instantiated instance of script MySQLAsync.MySQLAsync.
[ 1109] Started resource mysql-async
[ 1125] Started resource essentialmode
[ 1140] Started resource esplugin_mysql
[ 1172] Started resource es_admin2
[ 1172] ^3Couldn’t find resource es_extended.^7
[ 1187] ^3Couldn’t find resource esx_menu_default.^7
[ 1187] ^3Couldn’t find resource esx_menu_list.^7
[ 1187] ^3Couldn’t find resource esx_menu_dialog.^7
[ 1203] Authenticating server license key…
[ 2047] Server license key authentication succeeded. Welcome!
[ 2109] Sending heartbeat to live-internal.fivem.net:30110
[ 2109]
[ 2125] Current version: 5.0.2
[ 2125] Updater version: 5.0.2
[ 2125]
[ 2140] Everything is fine!
[ 2140]
[ 2172] Started map fivem-map-skater
[ 2172] Started resource fivem-map-skater
[ 2281] Loaded MySqlConnector, Version=0.38.0.0, Culture=neutral, PublicKeyToken=d33d3e53aa5f8c92 into ScriptDomain_1210322756
[ 2437] System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.ArgumentException: Format of the initialization string does not conform to specification starting at index 0.
[ 2437] at System.Data.Common.DbConnectionOptions.GetKeyValuePair (System.String connectionString, System.Int32 currentPosition, System.Text.StringBuilder buffer, System.Boolean useOdbcRules, System.String& keyname, System.String& keyvalue) [0x002a0] in :0
[ 2453] at System.Data.Common.DbConnectionOptions.ParseInternal (System.Collections.Hashtable parsetable, System.String connectionString, System.Boolean buildChain, System.Collections.Hashtable synonyms, System.Boolean firstKey) [0x0001c] in :0
[ 2468] at System.Data.Common.DbConnectionOptions…ctor (System.String connectionString, System.Collections.Hashtable synonyms, System.Boolean useOdbcRules) [0x00037] in :0
[ 2468] at System.Data.Common.DbConnectionStringBuilder.set_ConnectionString (System.String value) [0x00015] in :0
[ 2484] at MySql.Data.MySqlClient.MySqlConnectionStringBuilder…ctor (System.String connectionString) [0x00006] in C:\Users\Matthias\Documents\GitHub\MySqlConnector\src\MySqlConnector\MySql.Data.MySqlClient\MySqlConnectionStringBuilder.cs:17
[ 2500] at MySQLAsync.MySQLAsync.Configure (System.String connectionStringConfig, System.Boolean debug) [0x00000] in <6f835765886c4fada3e5ffb1ffcd6998>:0
[ 2515] at MySQLAsync.MySQLAsync.<.ctor>b__2_0 () [0x00047] in <6f835765886c4fada3e5ffb1ffcd6998>:0
[ 2515] at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
[ 2531] at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2547] — End of inner exception stack trace —
[ 2547]
[ 2562]
[ 2578] Server stack trace:
[ 2593] at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00048] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2593] at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2609] at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000e7] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2625] at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00008] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2625] at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 2640] at CitizenFX.Core.FunctionReference.Invoke (System.Int32 reference, System.Byte[] arguments) [0x00062] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrcore\FunctionReference.cs:62
[ 2656] at CitizenFX.Core.InternalManager.CallRef (System.Int32 refIndex, System.Byte[] argsSerialized, System.IntPtr& retvalSerialized, System.Int32& retvalSize) [0x00000] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrcore\InternalManager.cs:247
[ 2672] at (wrapper remoting-invoke-with-check) CitizenFX.Core.InternalManager:CallRef (int,byte[],intptr&,int&)
[ 2672] at (wrapper xdomain-dispatch) CitizenFX.Core.InternalManager:CallRef (object,byte[]&,byte[]&,int,byte[],int&)
[ 2687]
[ 2703] Exception rethrown at [0]:
[ 2718] at (wrapper xdomain-invoke) CitizenFX.Core.InternalManager:CallRef (int,byte[],intptr&,int&)
[ 2718] at (wrapper remoting-invoke-with-check) CitizenFX.Core.InternalManager:CallRef (int,byte[],intptr&,int&)
[ 2734] at CitizenFX.Core.MonoScriptRuntime.CallRef (System.Int32 refIndex, System.Byte[] argsSerialized, System.Int32 argsSize, System.IntPtr& retvalSerialized, System.Int32& retvalSize) [0x00013] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrcore\MonoScriptRuntime.cs:151
[ 2765] Error running system event handling function for resource mysql-async: citizen:/scripting/lua/scheduler.lua:41: Failed to execute thread: citizen:/scripting/lua/scheduler.lua:663: An error happened while calling export mysql_configure of resource mysql-async (citizen:/scripting/lua/MessagePack.lua:830: missing bytes), see above for details
[ 2781] stack traceback:
[ 2781] [C]: in function ‘error’
[ 2797] citizen:/scripting/lua/scheduler.lua:663: in method ‘mysql_configure’
[ 2812] lib/init.lua:3: in upvalue ‘handler’
[ 2828] citizen:/scripting/lua/scheduler.lua:175: in function citizen:/scripting/lua/scheduler.lua:174
[ 2828] stack traceback:
[ 2843] [C]: in function ‘error’
[ 2859] citizen:/scripting/lua/scheduler.lua:41: in field ‘CreateThreadNow’
[ 2875] citizen:/scripting/lua/scheduler.lua:174: in function citizen:/scripting/lua/scheduler.lua:138
[ 2890] hitch warning: frame time of 775 milliseconds
[ 182125] Sending heartbeat to live-internal.fivem.net:30110
[ 198890] Connecting: trainergames
[ 199640] Sending heartbeat to live-internal.fivem.net:30110
[ 233359] Loaded System.Threading.Tasks.Extensions, Version=4.1.1.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 into ScriptDomain_1210322756
[ 233515] [ERROR] [MySQL] An critical error happens on MySQL for query “SELECT * FROM users WHERE identifier=@identifier; {identifier=steam:110000104790009}”: Object reference not set to an instance of an object. at MySqlConnector.Core.ConnectionPool.GetPool (System.String connectionString) [0x0001a] in C:\Users\Matthias\Documents\GitHub\MySqlConnector\src\MySqlConnector\Core\ConnectionPool.cs:363
[ 233531] at MySql.Data.MySqlClient.MySqlConnection+d__83.MoveNext () [0x00012] in C:\Users\Matthias\Documents\GitHub\MySqlConnector\src\MySqlConnector\MySql.Data.MySqlClient\MySqlConnection.cs:376
[ 233547] — End of stack trace from previous location where exception was thrown —
[ 233562] at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233578] at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233578] at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233593] at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233593] at System.Runtime.CompilerServices.TaskAwaiter1[TResult].GetResult () [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0 [ 233593] at System.Runtime.CompilerServices.ConfiguredValueTaskAwaitable1+ConfiguredValueTaskAwaiter[TResult].GetResult () [0x0001e] in <4ac30274d31c4b8099694c24336fcb22>:0
[ 233609] at MySql.Data.MySqlClient.MySqlConnection+d__25.MoveNext () [0x00074] in C:\Users\Matthias\Documents\GitHub\MySqlConnector\src\MySqlConnector\MySql.Data.MySqlClient\MySqlConnection.cs:169
[ 233609] — End of stack trace from previous location where exception was thrown —
[ 233625] at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233625] at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233625] at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233640] at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233640] at System.Runtime.CompilerServices.TaskAwaiter.GetResult () [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
[ 233640] at MySQLAsync.Operation`1+d__7[TResult].MoveNext () [0x000aa] in <6f835765886c4fada3e5ffb1ffcd6998>:0
[ 233656] hitch warning: frame time of 557 milliseconds
[ 379687] Sending heartbeat to live-internal.fivem.net:30110
[ 559734] Sending heartbeat to live-internal.fivem.net:30110
[ 739797] Sending heartbeat to live-internal.fivem.net:30110
[ 919875] Sending heartbeat to live-internal.fivem.net:30110
[ 1065281] trainergames: admin
[ 1073625] Error running call reference function for resource es_admin2: citizen:/scripting/lua/scheduler.lua:351: server.lua:310: attempt to index a nil value (local ‘user’)
[ 1073672] stack traceback:
[ 1073672] server.lua:310: in upvalue ‘ref’
[ 1073672] citizen:/scripting/lua/scheduler.lua:337: in function citizen:/scripting/lua/scheduler.lua:336
[ 1073687] [C]: in function ‘xpcall’
[ 1073687] citizen:/scripting/lua/scheduler.lua:336: in function citizen:/scripting/lua/scheduler.lua:335
[ 1073703] stack traceback:
[ 1073703] [C]: in function ‘error’
[ 1073718] citizen:/scripting/lua/scheduler.lua:351: in function citizen:/scripting/lua/scheduler.lua:322
[ 1073750] Error running call reference function for resource essentialmode: citizen:/scripting/lua/scheduler.lua:351: citizen:/scripting/lua/MessagePack.lua:830: missing bytes
[ 1073765] stack traceback:2
[ 1073765] [C]: in function ‘error’
[ 1073765] citizen:/scripting/lua/MessagePack.lua:830: in method ‘underflow’
[ 1073781] citizen:/scripting/lua/MessagePack.lua:465: in field ‘any’
[ 1073781] citizen:/scripting/lua/MessagePack.lua:860: in field ‘unpack’
[ 1073797] citizen:/scripting/lua/scheduler.lua:563: in upvalue ‘callback’
[ 1073797] server/main.lua:160: in upvalue ‘ref’
[ 1073812] citizen:/scripting/lua/scheduler.lua:337: in function citizen:/scripting/lua/scheduler.lua:336
[ 1073812] [C]: in function ‘xpcall’
[ 1073812] citizen:/scripting/lua/scheduler.lua:336: in function citizen:/scripting/lua/scheduler.lua:335
[ 1073828] stack traceback:
[ 1073828] [C]: in function ‘error’
[ 1073843] citizen:/scripting/lua/scheduler.lua:351: in function citizen:/scripting/lua/scheduler.lua:322
[ 1073843] hitch warning: frame time of 271 milliseconds
[ 1099937] Sending heartbeat to live-internal.fivem.net:30110
[ 1279984] Sending heartbeat to live-internal.fivem.net:30110
[ 1428781] Sending heartbeat to live-internal.fivem.net:30110


#7

The first thing I would take care of would be these missing resources. Getting those working properly may resolve most if not all of the issues you’re having.

If you can get those running, post the startup log after.


#8

Do you know what folder those are suppose to go in?

I have been trying but am having trouble finding anything on why it can’t find them…


#9

By default, all ESX resources get dropped into a folder called [ESX] so if you were looking to place one of these resources, the dir structure would look like:

/resources/[ESX]/esx_menu_default

Then in your server.cfg you would start it with esx_menu_default. One thing to keep in mind is that some scripts have to be started after other scripts because they are dependent on them. Here’s an example of what your resource list should look like in server.cfg

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start scoreboard
start playernames
#inserted trough ZAP ressourcesystem
start mysql-async
start essentialmode
start esplugin
start es_admin2
start async
start cron
start es_extended
start esx_barbershop
start esx_clotheshop
start esx_datastore
start esx_garage
start esx_identity
start esx_lscustom
start esx_menu_default
start esx_menu_dialog
start esx_menu_list
start esx_property
start esx_shops
start esx_sit
start esx_skin
start esx_vehicleshop
start esx_weashops
start es_camera
start instance
start skinchanger

And here’s the dir structure that I know to work(click for biggies):

resource root:

and inside [ESX]:

Give that server.cfg and dir order a shot and see how it works for you.