Whenever I try to join a certain server, it gets halfway done downloading assets then doesn't move

To receive support, please fill out the following template, and remove this top text.

GTA V version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) N/A
System specifications
i-7-8700
nvidia GTX 1080
What did you do to get this issue?
Had to re-install fivem and tried to join
What server did you get this issue on?
Innocence RP
CitizenFX.log file N/A
.dmp files/report IDs N/A

If an issue with starting:
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder
FiveM client folder screenshot
Did you try to disable/uninstall your Anti-virus?

Also add what you already tried so far.

Tried reinstalling, restarting computer, clearing cache

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Download what you can, when it stops, disconnect then rejoin, and see if it picks up where it dropped off.

it comes back to where it dropped off but it stays stuck

issue fixed itself