# want to only allow players authenticated with a third-party provider like Steam?


want to only allow players authenticated with a third-party provider like Steam?

#sv_authMaxVariance 1
#sv_authMinTrust 5

The stock server.cfg does not allow non-steam to join. Do you uncomment one or both or set them to 0 to allow non-steam to join?


Since the introduction of player licenses those options don’t do a anything when it comes to (non-)steam users trying to join.
If you only want players to join with steam enabled, you’d have to create a resource for it yourself.

A very simple example of such script would be something like this:


AddEventHandler('playerConnecting', function(name, setCallback, deferrals)
    -- mark this connection as deferred, this is to prevent problems while checking player identifiers.

    -- letting the user know what's going on.
    deferrals.update("Checking for steam identifier...")

    -- save source
    local s = source

    -- check for steam identifier
    local allowed = false
    for id in ipairs(GetPlayerIdentifiers(s)) do
        if string.find(id, "steam:") then allowed = true end -- if the identifier is a steam identifier, allow the player.
    if allowed then
        deferrals.done("Sorry, you need to be running steam before you can join.")


I’ve tried joining with those settings above, with Steam killed via Taskmanager, and cannot join. Steam is not a required element to play FiveM. My GTA V is Social Club only. I have steam and do not like it. I would like to be able to join without Steam. How can I do this?


If the server has a Steam validation requirement then you’re not going to be able to play on that server.


I would be the one setting that requirement. How do I set no steam required?


Dont create a resource for it?


You guys don’t seem to be reading the question.

FiveM stock. No Steam? No Join! (This bad)

How to fix? No Steam! Yes Join!!! (This good)

Make good!!


FiveM stock allows you to connect without steam. Check your resources, if you are assembling from releases, you might have something on your server you don’t know about.


A totally Stock FiveM client installed from the .exe with no modifications. Updates as normal.

FiveM Client Popup Message:
Connection failed
This server requires you to be logged into the Steam Client

That server.cfg
#want to only allow players authenticated with a third-party provider like Steam?
#sv_authMaxVariance 1
#sv_authMinTrust 5

Same message from two different pcs.


That definitely isn’t a stock server, then. There is no such message in any official source code, and messages don’t get invented from thin air.

Try removing any random resource you might have added.


Confirmed. MelloTrainer…

AddEventHandler( ‘playerConnecting’, function( name, cb )
if ( Config.settings.steamOnly ) then
local id = DATASAVE:GetIdentifier( source, “steam” )

	if ( id == nil ) then 
		cb( "This server requires you to be logged into the Steam client." )

end )

Thanks All!



I have similar problem. Just build a FXServer and cannot join to it, because I have the Rockstar Shop version, not bought from Steam Games.

Server says that I am a “bad guy” (= I am the pirate version user).

So, legal Rockstar version users can not play FiveM?

I think the piracy protection By Rockstar is the Social Club. And I think that Steam protection is this logging-in-Steam kind of… Is there coming fix/ upgrade to FiveM that legal Rockstar players can join this FXServers too?


all you need to do is have steam running in the background you dont actually need the steam version to play.


Here’s an updated version of Vespuras code mentioned above that accually works, verify_steam-server.lua