vMenu v3.0.3 - A server-sided menu including (almost) full permissions support

vMenu v1.1.7 (hotfix)

Small update, fixes a bug that caused files like bans.json breaking whenever weird characters (or non-ascii) characters were used (often in someone’s username).
While I was fixing that, I’ve also added formatting to the bans.json file for easier reading. note that you should not edit the bans.json directly, ESPECIALLY WHENEVER THE SERVER IS RUNNING.

Download

Hello, I have the permissions.cfg setup the way I want, but no one can use any weapons except me. They are all locked for everyone Here is my config file. Also just a side question, is there anyway that I can make the default voice setting set to 20, and not allow everyone to change it? Its bad for people to be able to change it because its easy to meta game with it.

https://pastebin.com/6NN3wZpm

1 Like

this is a great menu love the design keep it up

1 Like

My admin on vmenu inst working iv been trying to fix it but i wont work

The only permissions i have are the basic ones such as misc settings, it does not come up with the options to spawn in cars or guns or anything.

This is what i did in my server config

you probably don’t want to change these!

exec permissions.cfg

But it saying in the console “cant find permissions.cfg”
But when i download it, It the name is permissions and when i look at videos it says permissions.cfg but mine is still a CFG file can anyone help

1 Like

Read the instructions… 1. Here you can do one of the following:
A. Copy the permissions.cfg file (from /resources/vMenu/config/ ) to the same folder where your server.cfg file is located. Then add exec permissions.cfg to the very top of your server.cfg file. Or;
B. Add exec resources/vMenu/config/permissions.cfg to the very top of your server.cfg file.

1 Like

In the weapon options section, make sure you give players access to this:

add_ace builtin.everyone "vMenu.WeaponOptions.Spawn" allow

Then give them the permission for every single weapon you want them to be able to spawn/modify.
for more info about each permission node, check docs.vespura.com/vmenu/permissions-ref

No there’s no way to limit or set a default for this, because it’s user preference. If you want to force a certain distance, you’ll have to remove all permissions related to the voice chat menu for all of your players (even staff/admin) then use something like vVoice to lock it for everyone.

That looks fine.

Are you sure you’ve copied your permissions.cfg file to the same folder where your server.cfg is located?

This is probably your windows explorer settings not showing the file extension, if it’s still a CFG file then that’s all fine because it’s still called permissions.cfg.

Are there videos explaining how to install vMenu? :open_mouth: never seen those before.

I got it working. Thank you for making this! Works awesome!

hey, nice menu but i cant access the _resorce.lua to load it, i know it says (’’ 1. Extract the folder vMenu and place it inside your /resources/ folder (THE FOLDER NAME IS CASE SENSITIVE, THE RESOURCE WILL BREAK IF YOU FAIL TO NAME IT CORRECTLY). If you did it correctly, you’ll end up with the __resource.lua file being right here: /resources/vMenu/__resource.lua .’’) but i copy the right name and i still dont see the _resorce.lua… any idea’s?

you didn’t download the correct file, you downloaded the source files. download the release instead.

ok, thank you, i will download it now.

Went through most of the posts and cant find anyone else getting the vmenu resource time warning in the lower right corner how can I fix this I’ve went through the steps what am I doing wrong.?

Is it constant?
Or only when opening some menus for the first time/after joining the server?

Joining and sometimes not all the time opening and closing menus. I turned off weather and time sync thinking it was doing it but did not help.

The warning on join is normal, nothing that can be done about this and it will happen almost every time you join.
The occasional warning that you get opening some menu for the first time is caused by NativeUI, nothing I can do about it (unless I decided to rewrite NativeUI, which is not what i’m planning on doing because it’d take forever and is probably not worth the result).

Thanks for the quick response. Glad to to know we installed it correctly

any way to shut off the time and weather so i can just use vSync? if i keep vSync i run into a glitching timezone lol

I managed to install correctly, and to use most of the menus however in my server the time keeps changing automatically every second … every 1 second changes to day, night, rain etc what could this be?

Yes, if you read the docs you’ll know how to. docs.vespura.com/vmenu/configuration

Probably an existing time/weather sync resource that interferes with vMenu. Look at the link above to disable vMenu’s weather and time options, or remove your other sync resource.

Any way you could add in for admin use in the menu to assign different groups to a player instead of through the permissions.cfg? Say i wanted to make a group for police, and give them extra permissions over normal players. Instead of having to go into the file and adding everyones ip or steam account to that group, could you do it through the menu instead?

Not through the menu, but if you add them to a group in the server console (the same command you’d put in the permissions.cfg add_principal [...]) and then tell your player to rejoin the server.

Of course this won’t save it to the permissions.cfg file so you’ll have to add it there as well for whenever you restart the server later on.