vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#3145

You probably messed something else up, vMenu can’t possibly cause this


#3146

vMenu will not cause the no spawn thing… probably running another script… may want to look at server logs


#3147

i can’t figure out to download this. i was told to do it, to fix my vmenu not working


#3148

You mean this issue?


#3149

me and some other people are having an issue on a server that has just started using VMenu, if we crash and rejoin we cannot use vmenu unless we restart our computers or the server admin restarts the resource.
is there a better way to fix this than restarting everytime you crash?


#3150

Define “crash”, like actually the game closes? Or does it just disconnect from the server?

Also I’ve never had this issue or anyone report it to me either, I have no clue why this would require a server reboot or a pc reboot, because vMenu just loads anytime you join :confused:

Any errors? Send the CitizenFX.log file from your FiveM installation folder next time this happens (send it whenever you’ve rejoined and tried to use vMenu), and then also send the log from before you re-joined after crashing (which should be named CitizenFX.log.1 if you’ve restarted FiveM (only once) after crashing).

Also, I’d like to know a couple of things:

  • When did this start happening?
  • Which vMenu version is that server using?
  • Which FXServer artifacts version is that server using?
  • If possible, share the server IP + Port here or PM me so I can check the resources list.

#3151

Ill respond on Mick’s behalf as a Director of the community. So for our server that we run, me and David we currently have vmenu installed on our server however we also have lambda and scripthook Enabled. It seems we are getting many issues with vmenu that also error on onesync and normal 32 slot servers. People are crashing and not being able to open their menu’s when pressing [Home]. They are then unable to open vmenu unless they restart their game again. I unforuently have no citizenFX.log for you, but I can try nap one off someone. And other times, people load in without perms when they have the same discord roles as everyone else.

We are using vMenu v2.2.2
We are using latest FXServer (1117)
fivem.sosarp.net:30120 ( 32/32 )


#3152

Doesn’t matter anymore seems to be working, we took onesync off, so that may be the problem if you wanna test it out.


#3153

Are you relying on discord identifiers? Because they are no longer reliable since apparently discord has changed their API and now it’s not working all the time (if at all).

So if people are whitelisted to use vMenu based on discord ID, and not able to use the menu, then that’d explain a lot.

As for the issue of not being able to open the menu when pressing [Home], I’m assuming you set the key to that? As the default is M for vMenu.

I’ve done quite a lot of testing on OneSync, no issues so far :confused: however I’ve never had enough testers to run > 32 players online at a time.


#3154

No, we are not relying on discord identifiers, we are using our own system.

Yeah, we change all that in the settings, we had it on M on testing and still had the same issues.

That’s understandable, not sure if we can really help there as it would be difficult to do that on a private server. Ill let you know if we have any issues from now on. Cheers


#3155

If anyone has a case of “can’t open vMenu”, let them try vmenuclient dump in the F8 console and tell them to send their CitizenFX.log file inside their FiveM folder. That’s pretty much all the info they can provide so I can look into any potential crashes.


#3156

Yeah, well when we go testing again, ill make sure to get a log for you. Thanks for the assistance.


#3157

the players on my server use the extra vehicle to repair their car

would there be a way to block this so that the extra or livery vehicle does not repair the vehicle when that apply


#3158

GTA V version?
1.0.1604.1
Up to date?
I believe so.
Legit or Pirate copy?
Legit
Steam/CD/Social Club?
Steam
Windows version?
Windows 10 1803
Did you try to delete caches.xml and try again?
Yes
Error screenshot (if any)
N/A
System specifications
AMD FX-6300
GTX 750ti
What did you do to get this issue?
I joined my server and it didn’t work
What server did you get this issue on?
Divide Roleplay
CitizenFX.log file
https://pastebin.com/p9gWwR7v
.dmp files/report IDs
https://pastebin.com/zANjZp9q

I have tried the fix in My vmenu is not working and i tried everything. This did not solve the issue. One of my friends is also having the issue. I have put the CitizenFX log as well as my vmenuclient dump above so we can hopefully solve this.

Thank you for your time,

Rohzino


#3159

Simply make a script that does this on the player’s vehicle:

SetVehicleAutoRepairDisabled(vehicle, true)

#3160

the menu toggle button is set to F9. Make sure F9 is actually mapped in your game to the correct input (INPUT_DROP_WEAPON).

There’s no errors whatsoever in your log, vMenu loads fine and would be working fine if the correct key was bound/pressed. It also shows that you have in fact got permission to open the menu, so there’s literally nothing on vMenu’s side that’s “wrong” or “not working”. Everything loads fine, so it must be a keybind/keyboard issue, or alternatively if you can hear the menu/see the instructional buttons, but the menu itself is invisible, then in that case you have a broken map resource on that server.


#3161

So what I did was had a macro-binded to F9. This fixed the issue. I must’ve done FN + whatever it got binded to. Oops.


#3162

@Vespura We have had your menu in our server for the longest time and since you had the update where we could change the menu to a different key we immediately changed it to F1. Well everyone in our community is able to access the menu except for one person but he has completely reinstalled GTA 5 and also FiveM and has cleared everything.

What would be preventing him from accessing the vMenu? I have sat with him for hours and he still isn’t able to. Any ideas?


#3163

he literally said what to do


#3164

My friend is getting this error on client side
https://pastebin.com/as0QRmH9