vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#3103

I try to block the opening of the Menu (M key)
in one area it works with the other key but with your menu it does not work have you a solution

i use this

Citizen.CreateThread(function()
while true do
Citizen.Wait(0)

	if IsInCarMenu then
		DisableControlAction(0, 289, true) -- Disable F2 noclip = notwork
		DisableControlAction(0, 168, true) -- Disable F7 tptoway = notwork
		DisableControlAction(0, 244, true) -- Disable M vMenu = notwork
		DisableControlAction(0, 311, true) -- Disable K inventory = work
	else
		Citizen.Wait(500)
	end
end

end)


#3104

Enable it, then go to the misc settings menu and click save preferences.

Have you tried this solution?

That’s not possible, vMenu disables the menu toggle key and listens for disabled key presses.


#3105

Sorry, I mean for like everyone in the server.


#3106

No that’s not possible.


#3107

How do I remove this?
Imgur


#3108

You can’t do that atm.


#3109

oof…


#3110

would it be possible for you to add an option so that we can block the opening at certain places or on an action


#3111

You can do this if you make a c# resource and add vMenu as a reference, then in vMenu’s main client disable the menus. I’m not going to explain how, but it is possible.


#3112

Hi all can any one tell me wahts ahappen here i had this working yesterday on server and today i have redone same as befor on another server im working on and i get this error please help if you can

Started resource blips
Loaded vMenuShared.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_311425963
Loaded vMenuServer.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_311425963
Instantiated instance of script GHMatti.Http.RequestInternal.
Instantiated instance of script GHMatti.Http.Request.
Instantiated instance of script vMenuServer.BanManager.
Loaded Newtonsoft.Json, Version=11.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed into ScriptDomain_311425963
^3[vMenu] [WARNING] vMenu is set up to ignore permissions!
If you did this on purpose then you can ignore this warning.
If you did not set this on purpose, then you must have made a mistake while setting up vMenu.
Please read the vMenu documentation (^5https://docs.vespura.com/vmenu^3).
Most likely you are not executing the permissions.cfg (correctly).^7
Instantiated instance of script vMenuServer.MainServer.
error in mono_error_set_method_load: Could not find method with signature string,string

Failed to instantiate instance of script vMenuServer.UpdateChecker: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.MissingMethodException: Method 'CitizenFX.Core.Native.API.SetConvarServerInfo' not found.
  at System.Runtime.CompilerServices.AsyncVoidMethodBuilder.Start[TStateMachine] (TStateMachine& stateMachine) [0x0002c] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at vMenuServer.UpdateChecker.CheckUpdates () [0x00023] in <499ae4d82e4a4e25b62ae75ca56b1bd2>:0
  at vMenuServer.UpdateChecker..ctor () [0x00006] in C:\projects\vmenu\vMenuServer\UpdateChecker.cs:24
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (System.Reflection.MonoCMethod,object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object[] parameters) [0x00002] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
   --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.InternalInvoke (System.Object obj, System.Object[] parameters) [0x00014] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at System.RuntimeType.CreateInstanceMono (System.Boolean nonPublic) [0x000a8] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at System.RuntimeType.CreateInstanceSlow (System.Boolean publicOnly, System.Boolean skipCheckThis, System.Boolean fillCache, System.Threading.StackCrawlMark& stackMark) [0x00009] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at System.RuntimeType.CreateInstanceDefaultCtor (System.Boolean publicOnly, System.Boolean skipCheckThis, System.Boolean fillCache, System.Threading.StackCrawlMark& stackMark) [0x00027] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at System.Activator.CreateInstance (System.Type type, System.Boolean nonPublic) [0x00020] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at System.Activator.CreateInstance (System.Type type) [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
  at CitizenFX.Core.InternalManager.CreateAssemblyInternal (System.Byte[] assemblyData, System.Byte[] symbolData) [0x00069] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrcore\InternalManager.cs:84
Started resource vMenu
Started resource CWRadarGun

#3113

That server is outdated, make sure to update the server and you should be fine.


#3114

ok that you


#3115

Hi, quick question… if some users have no action when press M (open vMenu) what should they do in?
Is there anyone facing same issue?


#3116

Capture
so when i add addon cars the name for the addon cars cuts off in the menu its like there is a limit on how long the name can be is there a way to increase it?


#3117

No-Fork license makes this useless.


#3118

Can someone please explain why I can’t active the menu on any server with vmenu, F1 doesnt work. Yes I have permissions everyone does.


#3119

If you actually read it, it says you can fork this if you want. And create PR’s, or keep it as a private edit. But you are not allowed to re-release vMenu, or parts of it, or forks of it. So you can’t make a topic about it/upload it to any other site.

So free to fork it, i have no problem with that :slight_smile:


#3120

F1 is not the menu toggle key by default.


#3121

I’m in the velocity drift servers all there menus are vmenu and none of the F keys work. All their shortcuts are F1 F2 F3 F6 F7 and the only one that works for me is F6… No one else on the serves are having issues. Vmenu also doesnt work for me in any rp server where vmenu is permitted for everyone.


#3122

Could either be that your keyboard layout/keyboard keybinds in GTA V is different. Or you might have (accidentally) changed or removed the keybinding for whatever velocity drift has set it to.

Either that, or vMenu crashes and doesn’t load at all.

Try:

  • resetting your (custom) keybindings in the GTA V pause menu settings page.
  • upload your CitizenFX.log file (inside your FiveM folder) here after you tried to use vMenu in any server that has it enabled, so in your case it’d make sense to do this on velocity drift.