vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#3043

i deleted my LSPDFR and my Vmenu is still not working


#3044

If you read above that’s not the only step you need to take.


#3045

So i don’t really have much information to provide, but upon starting my server with vMenu installed, i get a warning that says "Hitch Warning: Frame time of 295 milliseconds. But when i start the server with out vmenu installed i dont get that warning. Im paying for pretty much the premium stats for the server. Or is it a bug with the menu or a conflicting script.


#3046

That’s the update check, that’s completely normal and nothing to worry about. It’s only on initial start. This can’t possibly cause timeout issues.


#3047

ok. because some times vMenu it seems when i try spawning a custom vehicle it will take a while to spawn then I’ll get timed out. i dont know if its vMenu or if its something else.


#3048

vMenu will not load if the model isn’t properly streamed, whoever it will try to load the model if it’s correctly streamed, but just extremely massive. So that’s just a vehicle issue in that case, or your connection is very bad. It’s not a vMenu issue as there’s no way vMenu could cause a timeout if it actually waits until some model is loaded.


#3049

Something like that. ¯_(ツ)_/¯

The emblem/logo is superimposed over the t-shirt.


#3050

Can this mod be used in single player, or is it for fivem only?


#3051

Addon vehicles separated by vehicle class now… #Triggered
Ruined my Organization…


#3052

Looks like that’s just the badges/overlays which is already a thing @speedium

It’s a server side resource, so no you can’t install this client side.

Ok


#3053

No. This is the PedDecorationCollection, not badges. Just checked.

I did it like this
SetPedDecoration(PlayerPedId(), "mpluxe2_overlays", "MP_LUXE_LC_000_M")


#3054

Got a list of all those overlay dict names and overlay names?
Edit: nvm, these are actually considered “tattoos”. Hence they were never added.
I might add them in the tattoos menu, just because there’s no easy way to implement this in the clothing menu without having to redo the entire tattoos setup.


#3055

@speedium I’ve converted all new overlays using the latest files and combined them in a new collection, I’ll implement these into vMenu at some point when I’ve got time to refactor some more stuff.

https://d.fivem.dev/all-overlays-converted.json


#3056

How can I add MP Ped Customization to everybody but just MP ped customization


#3057

Player appearance menu and the mp ped customization can’t be enabled/disabled separately, they are both part of the vMenu.PlayerAppearance.Menu permission.


#3058

KK
Thank you


#3059

Yo @Vespura - I have 2 requests if you would be so inclined.

1- Add an option that will allow us to choose facial expressions in the Player Appearance > Ped Customization menu.

2- Add the ability to save weapons even if spawning weapons is blacklisted. On our RP server a lot of people use it to have multiple characters, but when they switch their guns are deleted because the ability to spawn guns using the menu is disabled. If it didn’t delete said weapons, people could freely switch characters.

<3


#3060

Switching ped models removes weapons because that’s how GTA does things sadly (or the script that changes ped models removes it manually) but vMenu doesn’t remove weapons when switching models. The latest version already includes a fix for this iirc.

They only work for mp peds though :confused: so i don’t see why this should be taken out of the mp peds section.


@speedium never realized there were >700 of these… https://streamable.com/qvskk it takes roughly 1 minute to go from index 0 to around index 370 and a little over 2 minutes if you want to cycle through all of them.


#3061

Can you help me fix my vMenu, it doesn’t seem to be working correctly, it says “[vMenu] [WARNING] vMenu is set up to ignore permissions!” I have followed all of your tutorials and it still doesn’t work and I don’t know if I configured it wrong or what but I’ve been told it is correct and so I don’t know what to do. I have it set up to use the permissions, the permissions.cfg is in the same directory as the server.cfg and I am executing it by using exec permissions.cfg at the top of the server.cfg line [Directly under the IP of the server located in the server.cfg] can you please help me?


#3062

What server artifact version are you using?
Type version in the server console/rcon and show the result.