vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#2943

@Vespura I just had this issue and my permissions are fine and addons isn’t broken, I updated my five m server files and it fixed it. Just thought i’d let you and others know.


#2944

This is caused by the decorators bug, there’s nothing that I can do about that.

Well, without info there’s nothing anyone here can do to help you. So either provide actual info instead of just saying “i changed it to something i’m not going to tell you what it is and now it doesn’t work”.

If you were using an ancient server version yeah then you’ll get all kinds of errors, this probably being one of them.


#2945

I changed the open trainer key to 288 (F1) but M is still the key that it uses


#2946

That’s still far too little information. Provide files, some description of things you’ve actually tried to do, is the permissions being executed (correctly) (and are you 100% sure about this, 99.9% of the people that’s 100% sure is 100% wrong, just fyi).


#2947

Permissions have nothing to do with my problem, but they do not work. Here are the lines that I changed

# Any valid control ID can be used here.
setr vmenu_menu_toggle_key 288
setr vmenu_noclip_toggle_key 289

#2948

The permissions.cfg 100% does have everything to do with it. If your permissions aren’t being executed then your permissions.cfg file isn’t either, and thus the convars won’t be configured either.


#2949

When admins go to spawn into players cars while they are invisible it causes them to be seen by other people, not sure if this was a bug or just how it is~


#2950

Why i cant remove the Voice Chat Settings? i tried to remove how do you put in the permissions and putting # but still working


#2951

I have no clue, I haven’t tested that specific case so I don’t know why it’d do that.

Well as long as you don’t provide the permissions.cfg or something nobody will be able to help you. Removing the permissions is what removes it for players.


#2952

I’ve updated to the latest version and now I’m getting this every time someone dies:

cfx> System.InvalidOperationException: Only extension types 10/11 (Citizen funcref) are handled by this class. 
at CitizenFX.Core.MsgPackDeserializer.UnpackExt (System.IO.BinaryReader reader, System.Int32 length) [0x00030] in /src/code/client/clrcore/MsgPackDeserializer.cs:357 
at CitizenFX.Core.MsgPackDeserializer.UnpackExt8 (System.Byte a, System.IO.BinaryReader reader) [0x00007] in /src/code/client/clrcore/MsgPackDeserializer.cs:316 
at CitizenFX.Core.MsgPackDeserializer.UnpackAny (System.IO.BinaryReader reader) [0x0000e] in /src/code/client/clrcore/MsgPackDeserializer.cs:32 
at CitizenFX.Core.MsgPackDeserializer.UnpackMap (System.IO.BinaryReader reader, System.Int32 length) [0x00017] in /src/code/client/clrcore/MsgPackDeserializer.cs:42 
at CitizenFX.Core.MsgPackDeserializer.UnpackFixMap (System.Byte a, System.IO.BinaryReader reader) [0x00005] in /src/code/client/clrcore/MsgPackDeserializer.cs:240 
at CitizenFX.Core.MsgPackDeserializer.UnpackAny (System.IO.BinaryReader reader) [0x0000e] in /src/code/client/clrcore/MsgPackDeserializer.cs:32 
at CitizenFX.Core.MsgPackDeserializer.UnpackArray (System.IO.BinaryReader reader, System.Int32 length) [0x0000a] in /src/code/client/clrcore/MsgPackDeserializer.cs:56 
at CitizenFX.Core.MsgPackDeserializer.UnpackFixArray (System.Byte a, System.IO.BinaryReader reader) [0x00005] in /src/code/client/clrcore/MsgPackDeserializer.cs:217 
at CitizenFX.Core.MsgPackDeserializer.UnpackAny (System.IO.BinaryReader reader) [0x0000e] in /src/code/client/clrcore/MsgPackDeserializer.cs:32 
at CitizenFX.Core.MsgPackDeserializer.Deserialize (System.Byte[] data, System.String netSource) [0x00018] in /src/code/client/clrcore/MsgPackDeserializer.cs:24 
at CitizenFX.Core.InternalManager.TriggerEvent (System.String eventName, System.Byte[] argsSerialized, System.String sourceString) [0x00021] in /src/code/client/clrcore/InternalManager.cs:202

When I stop vMenu no more error.


#2953

That’s caused by some resource that triggers some event when a player dies with the player coordinates in them. There’s nothing I can do about it since it’s not a vMenu issue. It’s a problem with any C# issue.


#2954

So the error going away after stopping vMenu does not mean that the problem lies with vMenu? How am I going to find the cause? Any tips?


#2955

It’s caused by any C# resource and any resource triggering such event. The elements mentioned this once and said you can safely ignore the error. There’s nothing I can do about this afaik without removing a lot of features from vMenu completely.


#2956

I understand that it can be ignored, I understand that it’s caused by a resource that has the player coordinates in them. I understand that vMenu is not the cause.

The thing I don’t understand is that there can nothing be done about it. I’d just like to find the resource that’s causing it and maybe disable that specific function using player deaths. So if it’s not vMenu, then where should I look?

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start scoreboard
start playernames
#inserted trough ZAP ressourcesystem
exec resources/vMenu/config/permissions.cfg
start vMenu
start mysql-async
start essentialmode
start esplugin_mysql
start es_admin2
start async
start cron
start es_extended
start instance
start es_camera

### ESX DEPENDECIES ###
start esx_addonaccount
start esx_billing
start esx_society
start esx_datastore
start esx_migrate

### ESX ###
start skinchanger
start esx_accessories
start esx_addoninventory
start esx_phone
start esx_ambulancejob
start esx_animations
start esx_atm
start esx_bankerjob
start esx_barbershop
start esx_basicneeds
start esx_boat
start esx_boilerplate
start esx_clotheshop
start esx_cruisecontrol
start esx_datastore
start esx_dmvschool
start esx_drugs
start esx_garage
start esx_givecarkeys
start esx_holdup
start esx_identity
start esx_joblisting
start esx_jobs
start esx_license
start esx_lscustom
start esx_mecanojob
start esx_menu_default
start esx_menu_dialog
start esx_menu_list
start esx_optionalneeds
start esx_phone
start esx_policejob
start esx_property
#start esx_randomevents
start esx_realestateagentjob
start esx_rpchat
start esx_service
start esx_shops
start esx_sit
start esx_skin
start esx_status
start esx_taxijob
start esx_vehicleshop
start esx_voice
start esx_weaponshop
#start esx_whitelist
#start esx_whitelistEnhanced
### End of ESX Pack ###
start es_ui


### put your custom ressources below this line! ###

start hrp_pd_impound
start LeaveEngineRunning
start bob74_ipl
start calmai
start disabledispatch
start semarmasreward
start weapondrop
start iplloader
start esx_jb_eden_garage
start jsfour-mdc
start jsfour-criminalrecord
start esx-checkdeathcause
start PlayerLogs

And on a side note, I love your resource and I appreciate the support with quick responses.


#2957

I have no clue which resource causes it. Usually some “rp_deaths” related resource or similar is known to cause issues. I don’t know the specifics about this problem.


#2958

Found it. Comment given by “nonn21” on github said:

Update es_extended\client\modules\death.lua to latest version

That fixed it (for me atleast). Strange it would only give the error when using vMenu. Maybe this helps you aswell or anyone having this issue after me.


#2959

So I have a problem with hitch warnings, they are constant and are getting bigger and bigger, i deleted both the vMenuClient.net.dll and vMenuServer.net.dll and it seemed to solve the problem, the only thing is its the files that run the menu, any way i can fix it,

forgot to mention everything is up to date


#2960

hitch warnings have absolutely nothing to do with the client dll. But yeah you basically remove the entire script by removing those two files, it won’t even start now.

so, are you talking about hitch warnings on the server side? or frame time warnings on the client side? Those are two completely different things.


#2961

Anyone else having an issue with weather… If you change the weather a few times… all of a sudden the script will wig out… and non-stop keep changing the weather… and lock out the ability to set it? Seems to be happening a lot lately for me.


#2962

solution… don’t change the weather so much… why do you need to change it anyways? also do you use vSync or any other weapon script?