vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

  1. 9.5.8
  2. Yes. I am using vMenu v2.2.1.


@Vespura hey im new to editing the vmenu we want only cops to have access to the vmenu and mods and admins. how can this be setup?
ive read up on your doc but didnt see much as to how to set it where cops can use it but not civs
any help would be apperciated



Are you sure the permissions.cfg is being executed correctly? Try adding this to the top of your permissions.cfg:

"Testing permissions.cfg execution"

like so:

You should see this error message in the console if the permissions.cfg is being executed correctly:

No such command Testing permissions.cfg execution.

If not, then the file isn’t executed.

It’s on there, though it’s not called “cops” just “admins” because this isn’t an RP menu. Though it works the same for any group.

1 Like


I had Newtonsoft.Json.dll in my GTA V directory, but I replaced it with the one in your vMenu package. Oddly enough the son of a bitch worked. Thanks for the advice.

1 Like


so how exactly do i add them to the staff section? how would i put there steam id in?
like im totally green to editing these files but a fast learner once showed lol

i wanna add 4 ranks basically, super admin, admin,mod,staff and staff being the cops



This should get you started on how to use aces and principals:

Then read this page for some important info specifically for vMenu’s permissions setup:


1 Like


The vMenu docs are now updated for vMenu v2.2.1 (config options and permissions). Additionally I’ve updated the permissions info page to include some new and updated information, including new examples and small “how-to” sections. Including: setting up group inheritance, and the most common mistakes.

1 Like


what do you change allow to if you dont want to allow it?



Fixed it, I just had to clear the other cashe, Thank you.

1 Like


when i start up my console it says the vmenu permissions are not enabled. Why? am i having this issue :frowning:



You’re not executing the permissions.cfg correctly in that case. docs.vespura.com/vmenu/

1 Like


that was exactly what it was :slight_smile: thanks buddy



sorry to bother but i set my identifiers for my admin mods etc but for some reason its not changing my perms i still cant see the kick ban selections nor time or weather selections honestly idk if its even giving me the correct perms :frowning:



well make sure you actually put the correct ids in.

1 Like


i am ; i even added the right id on vSync & now it says no perms for command with my ID idk whats going on with this stuff anymore! :frowning:



Then I’m guessing its the wrong id, or you’re using a steam ID but you aren’t actually running steam.

1 Like


i have steam running in the background ; fivem checks in with my steam “shows my steam name in top corner” just cant get these perms for admin



Well then it must be the wrong id. There’s simply no other way if you claim to have set things up correctly.

1 Like


any way i can send u some files from it to see what im doing wrong? i really wanna use this on my server!



yeah sure, but first make sure you’re using the correct identifier. For example, join (in FiveM) vespura.com:30122 to see your valid identifiers. You can use any of those for vMenu permissions.

You can upload your files to pastebin.com if you’ve verified that you’re using the correct identifier and send me the links.

1 Like