vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions
#2588

Is vMenu in a subdirectory? I.e. resources/vMenu/vMenu (it shouldn’t be if it is)

0 Likes

#2589

Negative ghost rider its just like this-------C:\FiveMServer\resources\vMenu

0 Likes

#2590

Are you sure you’re actually starting vMenu? and are there any client errors in your client CitizenFX.log file?

0 Likes

#2591

vmenu4 vmenu5

0 Likes

#2592
Loaded vMenuShared.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_630880217
[   3069625] Loaded vMenuClient.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_630880217
[   3069641] Instantiated instance of script vMenuClient.EventManager.
[   3069672] Instantiated instance of script vMenuClient.FunctionsController.
[   3069719] Instantiated instance of script vMenuClient.MainMenu.
[   3069719] Instantiated instance of script vMenuClient.MpPedDataManager.
[   3069734] Instantiated instance of script vMenuClient.NoclipMenu.
[   3069797] HostState transitioning from HS_HOSTING_NET_GAME to HS_HOSTED
[   3075828] Loaded Newtonsoft.Json, Version=11.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed into ScriptDomain_630880217
[   3076141] Error invoking callback for event vMenu:SetAddons: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: An item with the same key has already been added.

[   3076219]   at System.ThrowHelper.ThrowArgumentException (System.ExceptionResource resource) [0x0000b] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3076313]   at System.Collections.Generic.Dictionary`2[TKey,TValue].Insert (TKey key, TValue value, System.Boolean add) [0x0007c] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3076438]   at System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) [0x00000] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3076547]   at vMenuClient.EventManager.SetAddons () [0x00110] in C:\projects\vmenu\vMenu\EventManager.cs:116 

[   3076641]   at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)

[   3076734]   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3076844]    --- End of inner exception stack trace ---

[   3076922]   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00048] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3077016]   at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3077125]   at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000e7] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3077219]   at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00008] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3077297]   at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <a4e3abdd630b4c98a9d6f31a99197de6>:0 

[   3077391]   at CitizenFX.Core.EventHandlerEntry+<Invoke>d__5.MoveNext () [0x00064] in C:\gl\builds\edf06b9b\0\cfx\fivem\code\client\clrcore\EventHandlerDictionary.cs:85
0 Likes

#2593

i fixed it replaced the addon.lua didn’t know that would keep it from working…

thanks…

0 Likes

#2594

The issue was that you had the same addon car added multiple times in the list. This is fixed in some beta build but not yet in production. I’ll see if I can release this small update soon.

0 Likes

#2595

how can i give access ONLY to superadmin to the menu ?

0 Likes

#2596

Read the FAQ page on the docs.

1 Like

#2597

vMenu v2.2.1

https://docs.vespura.com/vmenu/changelog/#vmenu-v2-2-1-changes

Convar changes

new

  • vmenu_auto_ban_cheaters_ban_message Use this to set a custom auto-ban-cheaters ban reason/message.

Permission changes

new

  • vMenu.PlayerOptions.StayInVehicle Gives you access to the “stay in vehicle” option that prevents you from being dragged out of your vehicle.
  • vMenu.VehicleOptions.FixOrDestroyTires Allows you to use the tire fix/destroy list option to fix or destroy specific vehicle tires through the menu.

New submenu:

  • vMenu.PersonalVehicle.Menu Allows you to use the menu and set a vehicle as your personal vehicle.
  • vMenu.PersonalVehicle.All Allows you to use all features below.
  • vMenu.PersonalVehicle.ToggleEngine Allows you to toggle the engine remotely for your personal vehicle.
  • vMenu.PersonalVehicle.ToggleLights Allows you to toggle the lights state remotely for your personal vehicle.
  • vMenu.PersonalVehicle.KickPassengers Allows you to kick all passengers from your vehicle, they will have a 10 second timer to stop the vehicle if they’re driving it. If they refuse to stop then they will be forcefully kicked out of the vehicle after 10 seconds. If they do stop the vehicle within those 10 seconds they’ll automatically be tasked to get out of the vehicle.
  • vMenu.PersonalVehicle.LockDoors This allows you to lock and unlock your personal vehicle’s doors for all players. Anyone inside the vehicle is still able to get out of the vehicle if the doors get locked. If you are close to the vehicle, you can quickly double tap E on keyboard or L3 on controller (the vehicle horn button) to toggle locking/unlocking your doors.
  • vMenu.PersonalVehicle.AddBlip Allows you to add a blip for your personal vehicle.
  • vMenu.PersonalVehicle.SoundHorn Allows you to remotely sound the horn for 1 second. Fucks up if you’re inside the vehicle, so only use it whenever you’re outside of the vehicle for the best effect.
  • vMenu.PersonalVehicle.ToggleAlarm Remotely toggles the alarm on/off.

Other changes

  • Add suggestion by @NickM0822 (NickM0822 14 days ago: Add the ability to set a message for the auto ban of cheaters (like what it would say on the ban message)).
    You can now use this convar to set a custom auto-ban-cheaters ban message:
    setr vmenu_auto_ban_cheaters_ban_message "You have been automatically banned. If you believe this was done by error, please contact the server owner for support."
    
  • Update MenuAPI dependency version to v1.7 (and to v1.8 a few commits later to fix another bug) to fix a conflicting keybind for when the menu is open and you try to use the new DLC vehicle functions like boost or shooting rockets when using a controller/mouse.
  • Some internal cleanup of various files/code parts.
  • Fix null exception related to restoring weapons and the new weapon loadouts menu that occurred on re-spawn.
  • Change the dev permission to be disabled by default, and to only work whenever server debugging mode is enabled before the server is started. Requiring actual server owner intervention before I can help them debug stuff. This was something that shouldn’t have been designed the way it was in the first place, but it’s now changed.
  • Re-format locations.json and add some missing default locations for blips like barber shops and misc stores.
  • Update the GitHub bug report template.
  • Fixed a crash caused when the addons.json file contained multiple ‘addons’ using the same name. This is a user-error bug, but could’ve been prevented. This is now fixed, however you’ll get a warning telling you to fix your file. It’ll still work as intended in the mean time.
  • Fix weapons restore issue on skin-change (For more info see this topic comment.)
  • Add missing DLC weapon (weapon_stone_hatchet), as reported by @throwarray.
  • Add a warning message to the server console in case people didn’t execute the permissions.cfg or set vMenu up to ignore permissions. Looks like this:

    There is currently no option to disable this warning, that’ll come in a future update.
  • Add a ‘stay in vehicle’ option. This when enabled (in the player options menu) you will not be able to be dragged out of your vehicle by NPC peds that get angry at you.
  • Add a vehicle tires fix/destroy feature in the Vehicle Options menu.
  • Fix a crash caused whenever a user’s PC had broken timezones in their registry, causing an InvalidTimeZoneException to be triggered whenever using DateTime in the vMenu constructor, causing vMenu to stop working completely.
  • Add a server-console-only command to ban players. try /vmenuserver help for info.
  • Add Personal Vehicle menu.

Important support note

From this point on, only versions starting from vMenu v2.0.0 will be supported. Versions below v2.0.0 will no longer be supported. Please update. It’s not hard, and you’re doing everyone in your community a favor by using an updated and improved version.

Download here

2 Likes

#2598

All permission and convar related info is only available in the changelog for now. the proper docs pages (/configuration/ and /permissions-ref/) will be updated asap.

0 Likes

#2599

Is it possible to move some buttons? For example having TeleportLocations out from Misc or vehicle lights out from Mod to VehicleOptions

0 Likes

#2600

No that’s not possible.

0 Likes

#2601

Has the bodyguard feature been added yet? i’m not trying to rush you im just asking because you marked it Resolved in github so i was wondering what that meant.

0 Likes

#2602

Hey! This Release works fine so far, but if some players play a while (30 minutes) they get access to the Menu without my given permissions. I even tried some other Menus and got the same. So I think It’s my fault and I don’t know how to fix it, But If you want to help I would appreciate it. Thanks at all for reading! System

0 Likes

#2603

I marked it resolved because I was cleaning up the comments section and added all open suggestions to the “suggested but not yet being worked on” section on the original post in that issue :wink:

So no it’s not yet added, but it is still part of the suggestions :+1:

That’s really strange, PM me so we can look into this.

1 Like

#2604

Ok, I need to get home first :sweat_smile:

0 Likes

#2606

so even if vMenu is not setup to ignore permissions the message is still there?
because that warning message is on my console and I definitely do not have it setup to ignore permissions. I never ignore permissions in vMenu.

0 Likes

#2607

I need help with getting addon vehicles to work!

0 Likes

#2608

The message is only there if:

  1. You intentionally set vMenu up to ignore permissions.
  2. You didn’t execute the permissions.cfg correctly.
0 Likes