vMenu v3.0.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#2319

so I enabled it but if the person presses the key to open the menu it displays a message about the noclip is activated


#2320

cause your allowing no clip to everyone

Allow anyone to use noclip.

add_ace builtin.everyone “vMenu.NoClip” allow

put a # in front of it, and then if you want your staff to be able to use it you can do one of two things

change it to say - (DONT PUT A # IF YOU DO THIS)
add_ace group.moderator “vMenu.NoClip” allow

Make a new line under the one you put the # so it would look like this
#add_ace builtin.everyone “vMenu.NoClip” allow
add_ace group.moderator “vMenu.NoClip” allow


#2321

I already did it but the message appears the same way it seems to be some bug, type the noclip is disabled, because the message shows the same way


#2322

docs.vespura.com/vmenu

to delete normal saved peds, do so in the player appearance menu, there’s a option ‘delete saved peds’ and if you go there it shows a list of all your saved peds, clicking them will delete that saved ped.

ye that’s a bug, it’s been fixed in the beta build but not yet released. Either download the beta build or just wait.


#2323

you have done a fantastic job with the menu, but i happen to have some problems that i have encountered, 2 of which are major, 1 it the the menu is small and the options extend away, the second one the the admin set up, i need a way to find the steam license, i got the id but i dont know how to get the license, i would appreciate it if you could help me out.


#2324

define ‘the menu is small’? Lack of features? It’s physically small on the screen (like you can’t read the text)?

The options ‘extend away’? What?

You can use any identifier you want, you don’t need all of them. Steam ID works fine on it’s own. Join vespura.com:30122 in fivem if you want to find all your identifiers.


#2325

I’ve installed the vMenu , when i am in game i press M (to open menu) i get Noclip is now active. look at the blablabla. i can’t figure out why its not opening the menu, tried reinstalling everything.


#2326

When having a ultra wide monitor, you’re getting this:


#2327

Solution already posted many times in this topic.

That’s a bug whenever you don’t have permission to use the menu. It’s already solved in the beta build.

You don’t have permission to open it or it crashes somehow and doesn’t make any other menu besides the noclip menu.


#2328

Vespura: I’m sorry for bothering you that you gave me a oneline answer, instead of adding it to the description. This thread has over 2000 posts. Please, just cock down a bit. you’re awesome at what you do, we love it. But you gotta tone it down a bit.


#2329

What…?

What’s wrong with this?
What did you expect me to do? Answer the same question over and over and over again? Like you said, >2k replies. Probably >30% is me answering FAQ…
Please don’t say you expect me to provide 24/7 support and answer every single question even if it has been answered a million times already? Last time I checked I made this for free and support this in my free time. So you can’t be demanding answers like that.


#2330

can you please restart that server? i just read your post, thxs


#2331

It should be online just fine…?


#2332

Is there a way to turn off the voice chat?


#2333

Yes, remove all permissions related to the voice chat menu from everyone and vMenu will not handle any voice chat related stuff.


#2334

quick question how do i set new groups?


#2335

Just add players to it/add permissions to it. it’ll be automatically created that way. you can call it whatever you want, group.snail, group.admin, group.coolpeople, group.garcia, whatever you want :wink:


#2336

For the keyboard key codes, what list did you use? I tried to change the noclip and toggle menu to F10 and F11 but apparently it made the noclip be on mouse button 1


#2337

there’s a link on the vMenu docs (on the config page) that’ll take you to the FiveM docs.


#2338

Is there a way to set the voice proximity default value like the defaults set in perms?