vMenu v2.2.2 - A server-sided menu including (almost) full permissions support



@Chemical that’s the exact same issue @KeyWest was having. It’s most likely caused by a conflicting resource that adds a shit ton of decorators in-game. And vMenu is sadly the one that crashes because of it.

@Dmi_Shaw need more info, no info = no fix/help.

@xian same for you, need more info, no info = no fix/help.

@josherry I usually recommend replacing it, but you can also just keep your existing one and just add the missing/new permissions and convar options in. I always provide a list of changes specific to permissions and convar changes at the top of the changelog.


i have the same problem did u find a solution to it?


its not a vMenu issue, you just haven’t enabled PVP on your server.


where do i do that?


well you’ll need a resource that enables it, something like vBasic but I no longer provide support for that.


but does vBasic still work?


Yes it does.


ok will try that then


Hi ! What can i try to delete in menu source to solve this problem ?


Nothing, there’s nothing that can be done in vMenu to fix this, there’s another resource that registers an incredible amount of decorators. vMenu only registers 1.


Oh, okay (
I just installed old version of vMenu , and it works great !


Shouldn’t matter at all, because vMenu’s decorators haven’t changed at all in vMenu v2.2.1, v2.2.2 only checks if a decorator exists and then sets it if you enable an option in the menu, however it doesn’t actually create that new one at all.

It must be a broken resource on your server. (Not vMenu)


Ok i can make try to global search. What can i try to find in resources , any natives can do it ?


The best way to find the conflicting resource, is to disable them one by one until you find the one that conflicts with vMenu. If you find any then do let me know. Some natives you can look for:



Ok , thanks ,let me check :slight_smile:


Hello. I have one problem with vMenu permission. I tried add only staff members, but all players can use this menu? is this correct? How i add steam id corrects?
Thanks mate!


I am just now having this problem where when i hit F1 in servers that have vMenu, it will not open. I’ve tried relogging and uninstalling FiveM. It still won’t open, can someone please help? Reply or get to me faster at this email: prwarren18@gmail.com


F1 isn’t the default key to open vMenu.


I found some in essentialmode , main resource of rp mode :frowning:
Stance not a problem i can just remove it .
From started resources i got this :

DecorGetFloat :






By searching tag decor in essintailmode i got this :


the staff only part looks good, are you sure you’re actually testing with yourself removed from all permissions? And are you sure the permissions.cfg is executed?