vMenu v2.2.2 - A server-sided menu including (almost) full permissions support

menu
trainer
vmenu
servermenu
permissions

#2633

i have i remove the # in front of the all and put group,admin on the one that i dont what people to have and i save it and its exec in the server.cfg but it does not work idf it it is the vps i use but yea


#2634

Yeah that’s wrong obviously. Allowing .All allows all options in that submenu.


#2635

so i leave the # in the front of it and put what in front of the other ones. i really dont understand this and we are getting alot of people in our server now and i can have this


#2636

https://docs.vespura.com/vmenu/permissions-ref/#setting-up-permissions You should read this.


#2637

1548587112137-1532922533


#2638

I did that and saved it and restarted my server. And I still could get super cars


#2639

So, where i can change the default key to stop the noclip? Because on F2 i have jobs action :confused:

I have only setr vmenu_noclip_toggle_key 57 in permissions.


#2640

Dont Work Invisible ! And Multiple Turbo Car 2,4,8,16,32,64,524,1024


#2641

yes


#2642

What seems to be the problem with keybindings? Nothing work, even restarting the resource and the server, default key F2 for noclip is still active and M for menu to open/close is still a thing even though I put open/close on F10…
image


#2643


#2644

There is the vMenu file


#2645

There’s any way to make a “whitelist” of cars for each player?, so players can only spawn cars wich are whitelisted for them


#2646

You didn’t change the noclip key at all. You commented it out in your screenshot. If no (valid) control is specified, it will use the default value. If you want it disabled completely, set it to -1.

This is the error:

Newtonsoft.Json.JsonSerializationException: Could not convert string 'POStayInVehicle' to dictionary key type 'vMenuShared.PermissionsManager+Permission'. Create a TypeConverter to convert from the string to the key type object. Path 'POStayInVehicle', line 1, position 532. ---> Newtonsoft.Json.JsonSerializationException: Error converting value "POStayInVehicle" to type 'vMenuShared.PermissionsManager+Permission'. Path 'POStayInVehicle', line 1, position 532. ---> System.ArgumentException: Requested value 'POStayInVehicle' was not found.

Which basically means one of your files is (most likely) not up to date because it doesn’t know about one of the new permissions, which are clearly added into one of the other files because it clearly requests it. Try re-installing vMenu completely if updating somehow doesn’t work for you.

Nope, there’s far too many vehicles for this to work dynamically. Vehicles can be restricted per vehicle class.


#2647

Still not working, I have reinstalled it and does not pop up.


#2648

In my screenshot yeah, but in previous attempts before the screenshot, I actually edited the keybinding with no luck.


#2649

According to FiveM documentation with the controls and key codes. 57 is F10. Before my latest server reinstall it worked completely fine.


#2650

Dont Work Invisible ! And Multiple Turbo Car 2,4,8,16,32,64,524,1024 Vespura Can You Fix !?


#2651

If you start speaking English then maybe I can fix it yeah. Currently, however, I have no clue what you’re talking about.

Which server version are you using right now? And vMenu v2.2.1 right?

Try clearing your cache, maybe it’s a broken cache issue. Might also require your client (servers folder) cache to be cleared.


#2652

Due to the last update of vMenu i have an issue with invisible god mode and Torque Mulitplier setting…can u please tell me a fixate?