vMenu v2.2.2 - A server-sided menu including (almost) full permissions support



seems like vMenu is not you only problem, how the fuck can you even play GTA without any lag??

Anyway, usually this is caused because there are multiple errors being dumped to the console every frame because something has crashed, check the logs for any errors, warnings or noticeable messages.

vMenu being out of date is simple: just update. Instructions are on the docs.


So. I have tried atleast 20 times to change the “M” key to F1 like everyone else, but im still having zero luck. any input on this issue?


how do i make my addon cars show up in the addon section of the vmenu? ive searched and im unable to find any info




I Need Help Configuring my vmenu every time i do something in it and then go to my game it dose not work. i really need help


Edit permissions.cfg. Make sure you’re executing it also.


Really could do with some help, I have tried and tried watch so many tuts on this reason the doc and still can not get the permission to work.


Well, if you’ve read the docs, then you should know that you need to provide information whenever you ask for help. Provide permissions.cfg, and a list of things that you tried so far but you didn’t manage to get working.


The zap-hosting download is outdated, should i just update it with the files included in the forum?


Yes you can manually update it with the files from the releases page on GitHub. There’s nothing I can do about outdated zap builds, you’ll have to wait for them to update it if you want to use the one click installer to update.


Any chance of an option to keep your helmet/hat on when in a car?


Uhm no that’s not possible afaik. Only some hats/helmets allow for this.


ok thanks


Theres a little trick which could be useless depending on your purpose, I like to wear a helmet in rallycars for instance. I simply save the MP Character with the menu (with a helmet on), get in the car and load the MP Character again.


Ok so i’ve been messing with this the past day or so and have removed all scripts and more but still have this issue

I’m not sure whats causing it btw this is my home hosted but i’ve even tried using the zaphosting version. Still no luck.


You’re using an outdated fxserver artifact. Update your server.


Hey Vespura awesome menu, is there any way I can trigger event the menu to open? So you can only open it when you walk into a cricle for example. Thanks :wink:


Nope, not possible. It’s not planned either, because I intentionally made the control handling in MenuAPI something that can’t be disabled without completely disabling the menu toggle key. Which is not something that’s ever going to happen. There might be a way to enable the menu using some API, but there’ll never be a way to only open the menu with such API, and not using the menu toggle key.


So i updated to the 2.2.0 version and now I can’t open the menu in game. default keybind (M) does not work. any tips…




i changed the keybind to 288 (F1) still doesn’t work