Unloading popgroups.ymt crashes FiveM

crash
server

#1

Everytime i leave my test server where i’m streaming a popgroups.ymt file that works perfectly in game it crashes during the unloading process, i’ve only got the one popgroups.ymt so i haven’t tested with others.

The Error
[Window Title]
Disconnected

[Main Instruction]
FiveM has encountered an error

[Content]
An exception occurred (c0000005 at 0x1402aab25) during removing of resources:/assets/popgroups.ymt in data file mounter class CPopulationDataFileMounter. The game will be terminated.

If you require immediate support, please visit FiveM.net and mention the details in this window.

[^] Hide details  [Close]

[Expanded Information]
Crash signature: fivem.exe+2AAB25
Report ID: 643d7200-a18b-46cf-92a7-882da8fa4a84 (use Ctrl+C to copy)
Popgroups.ymt that i am using

__resource

files {
	"popgroups.ymt",
}

data_file "FIVEM_LOVES_YOU_341B23A2F0E0F131" "popgroups.ymt"

popgroups.ymt (182.0 KB)


#2

Changed topic title to be more concise


#3

i get the same error , i tried removing certain vehicles etc like if i alt f4 and reload its fine but if i go to esc-disconnect this happens or if the server is turned off all the clients receive that error


#4

Also experiencing this.


#5

i think it has something to do with FiveM while disconnecting whel you alt f4 you quit OK but the disconnect feature is crucial most of the time i hate to have to relaunch but idk if its because of an invalid model or FiveM trying to unload the file for that client when he leaves and it cant because the server uses it still or something


#7

Any idea if this is going to be fixed in a future build at all? I don’t want to have people crashing when they leave or are kicked.


#8

I would love to see a fix for this. Streaming the .ymt is a super easy way to achieve the results im looking for. But due to the error im not using it. Currently looking for other ways to achieve the same or similar results. It doesn’t make sense to use loops to remove something, when it could be removed from the server in the first place using the .ymt or .metas.


#9

This appears to be fixed now.


#10

Just checked. Same error when a player disconnects.


#11

Any updates on this? its still completely broken :frowning:

[   9023782] removing FIVEM_LOVES_YOU_341B23A2F0E0F131 resources:/vehicles/data/popgroups.ymt.
[   9023782] GlobalError: An exception occurred (c0000005 at 0x1402b33f1) during removing of resources:/vehicles/data/popgroups.ymt in data file mounter class CPopulationDataFileMounter. The game will be terminated.

6398e93e-07d8-481b-b6d3-27617b082e52.dmp (4.4 MB)


#12

Hey Frazzle, did you find any solution about your problem ?


#13

I’m getting the same exact issue every time when I’m disconnected from a server.


#14

Well i had for a moment : a similar issue !

I found out a way to counter it but not a real solution. I found that when we “disconnect” from our server using the client console it cause a crash after, when you’ll reconnect !

I think the file isnt correctly supressed so it cause a conflict when your client try do load, again, the concerned file !

Sorry for my english. But your solution is just to dont leave your game using “disconnect” command in the F8 console or in the echap menu. You can use “quit” but it will close five m.

Hope it will help !