Ubuntu 16.04 don't start

linux
ubuntu

#1

Hey, i have tried 5 times now and not coming anywhere so no i am posting this topic.

when i run my server it says this in terminal:

Initializing Mono
Initializing Mono completed
Hello!
Found new resource fivem in /root/Server-Files/resources//fivem
Found new resource fivem-awesome1501 in /root/Server-Files/resources//fivem-awesome1501
Found new resource fivem-map-hipster in /root/Server-Files/resources//fivem-map-hipster
Found new resource fivem-map-skater in /root/Server-Files/resources//fivem-map-skater
Found new resource runcode in /root/Server-Files/resources//runcode
Found new resource ragdoll in /root/Server-Files/resources//ragdoll
Found new resource betaguns in /root/Server-Files/resources//[test]/betaguns
Found new resource gameInit in /root/Server-Files/resources//[test]/gameInit
Found new resource keks in /root/Server-Files/resources//[test]/keks
Found new resource mapmanager in /root/Server-Files/resources//[managers]/mapmanager
Found new resource obituary in /root/Server-Files/resources//[gameplay]/obituary
Found new resource irc in /root/Server-Files/resources//[gameplay]/irc
Found new resource obituary-deaths in /root/Server-Files/resources//[gameplay]/obituary-deaths
Found new resource playernames in /root/Server-Files/resources//[gameplay]/playernames
Found new resource channelfeed in /root/Server-Files/resources//[gameplay]/channelfeed
Found new resource rconlog in /root/Server-Files/resources//[system]/rconlog
Found new resource spawnmanager in /root/Server-Files/resources//[system]/spawnmanager
Found new resource hardcap in /root/Server-Files/resources//[system]/hardcap
Found new resource chat in /root/Server-Files/resources//[system]/chat
Found new resource sessionmanager in /root/Server-Files/resources//[system]/sessionmanager
Found new resource baseevents in /root/Server-Files/resources//[system]/baseevents
Found new resource scoreboard in /root/Server-Files/resources//[system]/scoreboard
Found new resource race in /root/Server-Files/resources//[gamemodes]/race
Found new resource race-test in /root/Server-Files/resources//[gamemodes]/race-test
Started resource sessionmanager
Started resource mapmanager
Started resource chat
Started resource spawnmanager
Started resource fivem
Started gametype Freeroam
Started resource hardcap
Started resource rconlog
Started resource ragdoll
cfx> Resolved live-internal.fivem.net:30110 to 151.80.44.223:30110
Sending heartbeat to live-internal.fivem.net:30110
Started resource fivem-map-skater
Started map fivem-map-skater

#2

Yeah? Everything is running as it should…


#3

I cant find it on the list


#4

Do you have a firewall blocking the connection?
Also wait about 5-15 minutes and check again, if it’s still not there restart the server and wait another 5-15 minutes.


#5

I have the exact same problem and I allowed 30120 UDP and TCP through iptables and ufw.


#6

Try direct connect to your server. Also could you give your server.cfg please?


#7

I have tried that and not succed

here you have my server.cfg

# you probably don't want to change these!
# only change them if you're using a server with multiple network interfaces
endpoint_add_tcp "0.0.0.0:30120"
endpoint_add_udp "0.0.0.0:30120"

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start scoreboard
start playernames

sv_scriptHookAllowed 1

# change this
#rcon_password yay

sv_hostname "server test"

# nested configs!
#exec server_internal.cfg

# loading a server icon (96x96 PNG file)
#load_server_icon myLogo.png

# convars for use from script
set temp_convar "hey world!"

# disable announcing? clear out the master by uncommenting this
#sv_master1 ""

# want to only allow players authenticated with a third-party provider like Steam?
#sv_authMaxVariance 1
#sv_authMinTrust 5

# add system admins
add_ace group.admin command allow # allow all commands
add_ace group.admin command.quit deny # but don't allow quit
add_principal identifier.steam:110000112345678 group.admin # add the admin to the group

# hide player endpoints in external log output
sv_endpointprivacy true

# server slots limit (default to 30)
sv_maxclients 32

#8

Hi, I got the same problem on my server, Ubuntu 16.04 too.

Do you got any SYN flood message in your syslog ?

What is weird is that the old CitizenFX version was working just fine.

Same for me, I even tried to disable UFW, but no error on server console and I can’t direct connect, it says there is no server.