Time out on entering server


#1

Hello,

I am experiencing an issue when anyone connects to a server that I have just made, the person gets into the game fine and after about 5 seconds up to 10 minutes the server times out for all that are on. There are no error logs in the console.


#2

I should also add that the server stays up and doesnt go down.


#3

What are you hosting your server on?


#4

Im running the server on a VPS


#5

@Boss said in Time out on entering server:

What are you hosting your server on?

Im running the server on a VPS


#6

@Michael shouldn’t matter. Perhaps your VPS is unstable


#7

@Boss said in Time out on entering server:

@Michael shouldn’t matter. Perhaps your VPS is unstable

The vps is stable as I have ran multiple websites and teamspeaks off it. I think it might be something client side or server side, nothing to do with the VPS itself


#8

@jwbjnwolf said in Time out on entering server:

@Michael Do note that gaming servers may use a considerably bit more resources to run than a website or a TeamSpeak server.

Also, VPS’ aren’t always the most appropriate for gaming servers. That’s why you’ll find hosts like mine (InstaFree.com) don’t allow the use of gaming servers on their VPS’.


#9

@jwbjnwolf I have kept a close eye on the resources that the server was using and it can hold the server quite well.


#10

Have you tried running it on your own PC w portforward to see what happens?


#11

@Boss Yes, it does the exact same


#12

What country are you in?

Jase Edit: US - Los Santos :wink:


#13

@Boss said in Time out on entering server:

What country are you in?

Jase Edit: US - Los Santos :wink:

I am in the UK


#14

No one really reported this… so should have something to do with the connection then


#15

@Boss @Michael actually I just purchased a nice VPS and had the server up and running and I time out on connection. And the server remains up. Here is a couple of the lines from the server.

2016-08-14 00:38:39.5148|INFO|CitizenMP.Server|no target netID 1
2016-08-14 00:38:40.1051|INFO|CitizenMP.Server|no target netID 1
2016-08-14 00:38:40.6098|INFO|CitizenMP.Server|no target netID 1
2016-08-14 00:38:41.1074|INFO|CitizenMP.Server|no target netID 1
2016-08-14 00:38:41.6120|INFO|CitizenMP.Server|no target netID 1
2016-08-14 00:38:44.2153|INFO|CitizenMP.Server|disconnected a client for timing out
2016-08-14 00:40:37.3674|WARN|CitizenMP.Server|A client tried to send an event of type baseevents:enteringVehicle, but it was not greenlit for client invocation. You may need to call RegisterServerEvent from your script.
2016-08-14 00:40:38.8388|WARN|CitizenMP.Server|A client tried to send an event of type baseevents:enteredVehicle, but it was not greenlit for client invocation. You may need to call RegisterServerEvent from your script.

#16

And what if you try again? Cause this;

2016-08-14 00:40:37.3674|WARN|CitizenMP.Server|A client tried to send an event of type baseevents:enteringVehicle, but it was not greenlit for client invocation. You may need to call RegisterServerEvent from your script.
2016-08-14 00:40:38.8388|WARN|CitizenMP.Server|A client tried to send an event of type baseevents:enteredVehicle, but it was not greenlit for client invocation. You may need to call RegisterServerEvent from your script.

Is normal…


#17

@Boss yeah I’ll try again tonight after work, but I tried about 3 times last night and the same thing. It would instantly say loading story mode and I’d join and it would say I timed out and then would have a red box top left. Thank you in advance for your time!


#18

I’m getting a time out similar when trying to connect locally to my server. It’s a 'no target netID"


#19

I’m getting it to. Any solution yet?