(Solved) Server CPU goes crazy and lags


#1

I have a big problem on my Linux Server Version 558 / Debian 8.

From yesterday cpu on my server randomly jumps to 100% and this causes terrible Lags in the game. I would like to add that 100% jumps at the same process as the FiveM server.

I will add that nothing has changed on the server and I’ve never had this problem before.

Sorry for my bad English.


CentOS issues?
555 + version mas CPU ussage and server lags
#2

Make Sure your server files are updated.


#3

Server Version 558 im using the last version.


#4

15 Players on server and my Cpu USSAGE IS:

Is this normal?


#5

Other people have also said that the >= 557 version causes hitches to appear in console, so that might be related to the high cpu usage spikes.

Try running the 507 version for a bit and see what happens.


#6

Ok i just updated my serwer to 507. Now i have to wait what happens.


#7

On 507 it works fine.

Thanks for help.


#8

Same here, running latest debin stretch with latest server files, have been getting them for a while now since it started suddenly happening, will try a downgrade later


#9

Try the newst version. I think they fixed it.


#10

My bad i have stil the same issue. :frowning:


#11

All versions above 555 cause massive CPU jumps and lags on the server.
I have to use 507 version to get my server works fine.

Fivem is going to take care of it? Because I’m beginning to worry that the day will come when we will have to use the latest version with these problems.


I host my server on VPS Debian 8
8gb Ram
2x cpu 3,1 GHz


#12

I had the latest version unless they updated it today,
the server CPU usage went down alot when I downgraded but issue still persists, I mean the server is only 1.6 ghz, but that is suppose to be enough, right?


#13

I think 1.6 is enough. I tried today 561 version but the issue is still


#14

All versions above 555 cause massive CPU jumps and lags on the server.
I have to use 507 version to get my server works fine.

Fivem is going to take care of it? Because I’m beginning to worry that the day will come when we will have to use the latest version with these problems.


#15

I downgraded my linux kernel from 4.9.06 to 4.9.0.5 and the problemt went away. Check what kernel ur running uname -a


#16

root@gta:~# uname -a
3.16.0-4-amd64 #1 SMP Debian 3.16.51-2 (2017-12-03) x86_64 GNU/Linux


#17

Consider upgrading to latest stable debian, Stretch


#18

Upgrading to debian 9?


#19

Yes, but also what CPU do you got, how many ghz?
People say oh fxserver is not cpu expensive but I get cpu usage of upto 30% and bursts of 50% on fxserver and upto 20% on proot with 18 player with an 1.6ghz cpu. I run 95 scripts (not including car mods) and some Scripts I did myself and others are just from fivem. My server is running on ESX and a copy of my server runs perfect on my main computers (windows) one has 2.7ghz (i7) and the other 4.2ghz (i5)


#20

On version 507 my CPU is max 10 up to 20% but on the new version 50 up to 100% (Lags on 100%).
My cpu is 3,1 GHz x2
I run 130scripts now on 507 with no problems.