[Solution] Forcing FiveM to use your discrete GPU | Infinite Loading Fix

orange-screen
infinite-loading

#21

Iam laptop


#22

Nice to meet you, I’m Jack. Please read the initial topic, this topic was initially created for laptop users having this issue. If you want to continue further with this conversation, DM me.


#23

I already tried that I have amd card


#24

Try this:

or, try this:


#27

Can anyone add screenshots of intel? I don´t know how to do it.


#29

(It appears my response was deleted? Odd).
My laptop has an i7-6700HQ and AMD Radeon R9 M375 (Lenovo Y700 14ISK). I’ve been running into issues with FiveM and the steps here don’t seem to work. Somehow, when I set it to high performance in Radeon Settings it worked - once - but I think I was not able to use the GUI (That was about a month or so ago).

Currently I have changed settings in Windows Settings. It appears to be under “Graphics Settings” instead of “Advanced Display Settings”, I am on Windows 1803 if that makes a difference.
Attached is a screenshot:
Windows Settings
I set FiveM.exe and FiveM.lnk as “High Performance” and tested by launching FiveM, however I continued to have the yellow screen issue.

Next, I tried changing settings in Radeon Settings.
Screenshots below:
Radeon Settings 1
And following another piece of advice I saw on YouTube:
Radeon Settings 2
Although I’m not sure what difference that makes.

Updated my Radeon drivers to 18.12.3, FiveM should be completely updated (AutoUpdated when I launched). Checking the changelog, I see this:

And when I open the FiveM console as I am stuck in the yellow screen I do see it hooking the .dll however nothing happens.

Any further steps I could try?

UPDATE:
Still does not really work, but on Discord I was linked this server:
https://servers.fivem.net/#/servers/detail/64.190.90.120:30120
which allowed me to load into the game and it works. However, it seems to be the only one that did – the two other servers I attempted to access through servers.fivem.net did not work.


#30

It was deleted because you DMd me. There’s no need to ask for support in two different places.


#31

Oh, my bad!


#32

I dont understand this part

  • Navigate to your FiveM directory, which, if you didn’t add a custom installation, will be in %localappdata%/FiveM .
    • Select FiveM.exe.
  • Click on ‘Options’.
    • Select “High performance”.
  • Save.

#33

Press the Windows key and type: %localappdata%/FiveM and press the folder, then, press FiveM.exe.


#34

I SOLVED IT

if making the prog High performance is not doing any thing to it then do as i say

1 - open Switchable application graphics settings

2- Press on Defaults

3- Keep every thing of the FiveM Not assigned

It worked for me :slight_smile:


#36

Read this:


#37

We have the same issues still the red dot initialize but nothing happend, GTX950M is the GPU but there is no Advanced Mode or anything like the description.

any ideas?


#38

I still am having issues, I can’t connect to certain servers and I am always stuck at the green screen. I use the console to be able to join servers, but for some reason each time I type in the IP, it shows this Getting auth" or whatever and it stops there… Help @JHodgson1


Infinity Loading screen stuck on color background - no menu
#39

Do you use any antivirus?


#40

Yes, and I turned it off restarted my FiveM, and It still does the same thing, I have exhausted so many assets to be able to figure this out, and my last resort is to factory restart, which I really don’t want to do.


#41

If possible do you have a discord I could contact you on to be able to show you? @JHodgson1


#42

If you could get back to me @JHodgson1 on my discord D.Cubbin#2961, I just got accepted to DOJ and I need this to be fixed somehow


#43

Please don’t mention me in every post you send, I’m busy with other things. I’d recommend creating a topic in #technical-support and provide more information using the template.


#44

I don’t have a “Advanced graphic settings” link, it shows “display adapter properties” and “connect to wireless display” is this because I have windows 10?