[Solution] Forcing FiveM to use your discrete GPU | Infinite Loading Fix

Hi!

There has been a recent influx in laptop users, this has also created a mass amount of users come on the forums and Discord regarding an issue that 'FiveM is stuck on orange/green/red/… screen", this is caused because the person’s laptop using the iGPU instead of the discrete GPU. This is an easy fix.

Try this first!

  • Open Windows settings.
    • Click on System.
      • Click on Display.
  • Under ‘Multiple displays’, click the Graphics settings link.

  • Select ‘Classic app’ under the ‘Choose an app to set preference’ dropdown box.
    • Then select ‘Browse’.
  • Navigate to your FiveM directory, which, if you didn’t add a custom installation, will be in %localappdata%/FiveM.
    • Select FiveM.exe.
  • Click on ‘Options’.
    • Select “High performance”.
  • Save.
  • Enjoy!

For NVIDIA GPUs

  • Right-click on any part of your desktop and select ‘NVIDIA Control Panel’.
  • Go to the desktop tab at the top of the control panel.
    • Make sure the "Add “Run with graphics processor” box is checked :heavy_check_mark:
  • Right-click on FiveM.exe and hover over the “Run with graphics processor” box and select “Change default graphics processor…”
    • Select “High-performance NVIDIA processor”
  • Enjoy!

For AMD Radeon GPUs

  • Right-click on any part of your desktop and select the ‘AMD Radeon Settings’.
  • Select ‘System’.
  • Press ‘FiveM.exe’.
  • Select your discrete GPU in the drop-down list.
  • Enjoy!

For AMD Catalyst GPUs

  • Right-click on any part of your desktop and select ‘Catalyst Control Center’.
  • Go to the “Power” tab on the left.
    • Select “Switchable application graphics settings”
  • Under this you will see “Add Application”
    • Navigate to your FiveM directory, which, if you didn’t add a custom installation, will be in %localappdata%/FiveM.
      • Select FiveM.exe
  • Open the dropdown list for graphics options.
    • Select ‘High Performance’.
  • Enjoy!

For Intel® Graphics GPUs

  • Right-click on your desktop and select Graphics Properties. This will open the Intel Graphics and Media Control Panel. Click on Advanced Mode and OK.
  • In the next window, click on the 3D tab and set your 3D preference to Performance. Click Apply.
    • Note: If, at the end of this process, Serato Video still doesn’t run, also de-select ‘Application Optimal Mode’
  • Now select the Power tab and set the Power Plans to Maximum Performance. If you sometimes perform with your laptop only running on battery, then select battery in the top right corner and also set it for Maximum Performance. Click Apply.
  • Enjoy!

Note: If somebody wants to provide screenshots for either the NVIDIA control panel or the AMD control panel, feel free to add them as this post is a wiki.

20 Likes