Simple Server Starter.bat Won't start!

help

#1

GTA V version? Steam
Up to date? Yes
Legit or Pirate copy? Yes
Steam/CD/Social Club? Steam
Windows version? 10
Did you try to delete caches.xml and try again? No
Error screenshot (if any) No
System specifications i5 4690k, GTX 960 4gb, 8gb ram
What did you do to get this issue? Try starting up server
What server did you get this issue on? My own
CitizenFX.log file
.dmp files/report IDs

If an issue with starting:
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder
FiveM client folder screenshot
Did you try to disable/uninstall your Anti-virus?

So I’ve been looking into starting my own server running off my local machine. I got everything setup with the FXServer. I go to click on “Simple Server Starter.bat” In my FXServer folder. All of sudden I get a “Windows CMD Prompt” and then is suddenly disappears. I keep trying and It keeps doing the same thing. Please somebody help, because I’m clueless on what to do,


#2

Without knowing the contents of your .bat file, we can’t help you.


#3

What would be the contents of my bat? and how can I get to it?


#4

That’s what I’m trying to find out. Right click it, open in Notepad (or ideally Notepad++, install it if you don’t have it), paste the contents into a Pastebin and link it here.


#6

https://pastebin.com/TqM6DDQS


#7

offtopic: I suggest uncommenting #sv_endpointprivacy true


You should start your server via command prompt. Open CMD and type:

C:\*FILEPATHTOFXSERVER*\run.cmd +exec server.cfg


#8

Weird, that should work. I run my run.bat as this and it works fine:

Are you sure you’re in the right directory and that everything the server needs is there?


#9

That’s what the .bat should do :stuck_out_tongue: It just makes it so you can click the bat file instead of having to type the command everytime.


#10

I’ve always used cmd :joy:

I know the wiki says to start via cmd as well, just never even tried running the .bat file tbh.


#11

The bat file just does the exact same thing as running it directly through Command Prompt, it’s just easier for some people to click the file rather than typing (or copying+pasting) the command.


#12

Maybe this will help. When I click on my file path in the folder this is what I got.

C:\Users*John Doe*\Desktop\FX Server FiveM Still doesn’t work. Same thing When I click the .bat file.


#13

Try adding PAUSE at the end of the .bat file.

Example:

.\run.cmd +exe server.cfg
PAUSE

What’s the output in the Command Prompt?


#14

Tried that got nothing. My CMD Prompt in the beginning C:\Users\John Doe>

The result I get when I type it in the CMD prompt Is. \run.cmd’ is not recognized as an internal or external command,
operable program or batch file.


#15

If anyone is available to hop in a dicord/teamspeak I’m available at this point and time.


#16

Are you running it from the FXServer directory? You need to be in the directory where all of your server files are. The run.bat also needs to be in that same directory, not outside of it.


#17

Yes, The FXServer folder is on my desktop. Everything is in the proper place.


#18

Can you paste your Bat file and your server directory please?


#19

A screenshot of your server directory contents would be helpful as well.


#20

sorry guys but im a total newbie with computers but heres my problem…

when i try and run serverstarter.bat it comes up “could not authenticate server license key”.

do i have to rent a server first before i do any of this? if anyone could help me with this it’d be much appreciated


#21

so do you have to have a folder on your desktop called “FXServer” and within that a folder called “FiveMServer” with all the files???

i just have my FiveMServer folder on my hard drive…