Server not appearing in broswer


#1

About a hour ago our server appear but it doesnt appear anymore. We have a big community and dont understand why it isnt showing. The server is Midnight RP. We have changed anything server wise. Is this a fivem issue or something on our side?


#2

Make sure this:

# disable announcing? clear out the master by uncommenting this
#sv_master1 ""

isn’t uncommented.


#3

Its not uncommented out at all we legit have touched a thing and it was just gone.


#4

Nihonium [via Discord]:
"…new servers only get added at a second heartbeat
which is a) when somebody joins or b) when executing heartbeat again or c) after 4 minutes"

Wait a few or connect then disconnect and look again at the server list to see if it’s there.


#5

We had up to 10 people direct connected and nothing. You also cant save it to history or favorites. Weve been up for almost 2 to 3 months. So im not sure why it wouldnt show the license key thing was dropped by esx. So its not a server key issue. Like im stuck.


#6

What do you mean by this?


#7

Esx v2. Unless there is still license key? If so this might be the problem


#8

Go to your server.cfg file and go to the bottom. There should be a line that says:

# Get a key from https://keymaster.fivem.net
set sv_licensekey "LICENSE KEY HERE"

You need to make sure there is a license key where it says "license key here"

Odd though, it should say something about the server key in the console if there is an issue. http://prntscr.com/hg01u0


#9

Ill try it out and see what happens


#10

Okay we updated to the newest build and add the server key still nothing.


#11

Any ideas? anyone? we’ve tried everything we know to try


#12

If you’re running a Windows server, make sure your firewall has an outbound rule to allow it to connect to the FiveM live server (internal-live.fivem.net I believe).


#13

what type of rule should it be? program port predefined or custom?


#14

that link is wrong we cant reslove a host


#15

You can add the fxserver to it and allow outbound rules, that should be enough.

Yea my bad, it’s live-internal.fivem.net


#16

Still the same issue nothing in browser will let us direct connect but wont show on the browser.


#17

You got anymore ideas?


#18

You’re not running any kind of antivirus software, right?

You’ve also done as Havoc said and made an exception for FXServer in your firewall?


I’m not sure what else could be the issue. I’ve thrown a server up and it shows in the browser.


#20

Nope, even tried using our old server box to launch the server, still didn’t show up on the list.

Also tried what Havoc said.

So far, we’ve already tried/checked the following:
-uncommenting #sv_master1
-waiting for the second heartbeat
-trying another port (our test server also does not show up)
-Added the server key
-made sure our firewall had an exception for the live list.


#21

You do not want to uncomment this. It will unlist your server (which will make it not show up in the server browser).