Server isn't visible/VPS not working either


#1

Hi all,

I’ve been trying to set up my server on my own computer for about a week now and it seems that no matter which solutions I attempt to use, none of them seem to be working. Only I am able to see my server on the server browser and only I can join it. Anyone else that attempts to join either cannot see it on the list or receives a “failed handshake” message when attempting Direct Connect. I’ve already tried:

• Adding inbound and outbound rules to the Firewall, for both TCP and UDP.
• Disabling my anti-virus completely.
• Opening port 30120 on my router.
• Setting up a DMZ to see if it made a difference.

All of which did nothing and made it impossible for others to see or join my server.

As a last resort, I’ve also spent money on a VPS and tried to set it up that way, which is now preferred as I’d rather the server be up all the time without it having it to be run on my computer. However, I’m now facing the same issue as before. Only this time, since my VPS has a different IP than my computer, I can now no longer connect to my server at all.

Any help from those who know about server visibility issues or setting up a FiveM on a VPS would be greatly appreciated.

Many thanks in advance,

Konflikt


#2

If someone find a solution please tell us.

We are in the same way. Can’t see our server since the patch was released.


#3

Hi,

I have the same problem thanks for helping :slight_smile:


#4

With this many occurrences, surely someone knows a solution?

I wouldn’t mind but it’s been about 2 weeks :disappointed:


#6

add the server exe as an exception the firewall, i had the same problem


#8

Any help would be appreciated…

Sorry to keep asking but it’s such an annoyance to have actually spent money on a server for it to break straight after.


#9

This is clearly not a FiveM issue, if you can’t connect even using direct connection (can you open http://ip:port/ in a browser, even? it should ‘404’, not ‘connection refused/timed out’) there’s clearly another issue going on.


#10

@neodymium Appreciate the response!

At the moment all I see when I go to that is this. I’ve tried every suggestion that people have given to me and have no idea.

I understand you’re probably busy working on FiveM right now, but I don’t suppose you’d know anything at all that I could try? It would definitely mean a lot given how long I’ve been trying to get this working unsuccessfully.

Nonetheless, thanks for the response again.

Kind Regards,

Konflikt


#11

Does the VPS you use have a firewall enabled by default?


#12

It does. I’ve switched it off though.

EDIT: Problem is now solved for me. For anyone that still gets the problem, I went into my VPS Firewall settings and adding in two new rules for the server. Make sure you add it as “citmp-server.exe”.

The main problem I’d noticed is I’d just (stupidly) been adding it as “server.exe”. Hope this in some way helps some people.

Thanks again for all the responses and especially @mendelevium for highlighting the Firewall issue :smile:

Kind Regards,

Konflikt


#13

I had this problem and then after a few days my server pop back online, I mean you guys say maybe its our problem, sure maybe but I do feel this new fivem update with the new server list may be causing this issue somehow. but hey Its just a feeling I got.


#14

I’ve added the rule to my firewall and still can’t see my server on the list or direct connect. I’ve even turned off the firewall and tested still no luck. Forwarded the ports, tried updated the server. Still nothing. Everything worked until the update a few days ago. :frowning: