Server invalid ref call error [FIXED]


#1

Hi there!

i have made my fivem server and it was running just fine, but suddenly my server gives the error invalid ref call and my F8 console is getting spammed with the same error.
The server also makes an console error with that exact message, but only on the commands like /setjob or /setmoney…
i do not know where i have to look since i have updated fivem and esx and other addons…


[Release][ESX] Properties
#2

Fixed it (20 char required)


#3

How did u fix it?

(20 char)


#4

Please tell , i am having the same error only in my F8 console and nowhere els . All this this afternoon and i can’t get my esx_statuts to work again and all this since the same error , so please share a fix


#5

I have the same exact issue on my 2 servers.
Removed cache, reinstalled client (total wipe of the old files) It didn’t work.

esx_status disappered.

edit:
I want my post to be as precise as possible.
Server was up and running for the night (GMT +0), today after client’s update i logged in and everything looked fine, but players were asking about hunger and thirst bar (esx_status). I had them, so I checked 2nd server - disappeared. I went back to my first server and all of sudden status disappeared as well.
I set up backup server (12h/24h/48h back) nothing helped.

Server cache/client reinstall. Nothing.

F8 Clientside console : invalid ref call attempt


#6

I am also having same problems, same problem on my localhost server and VPS. I had no problems at all before today but today hunger and thirst bars started to disappear for everyone on the server.


#7

The same problem! How fixed it?


#8

you could say how did you fix it :slight_smile:


#9

Also have the same problem since fivem update yesterday. Every time that error shows in the console it stops apartments from working to. Hope this is fixed soon because its causing pretty big problems on populated servers.


#10

how about 20 characters ??


#11

Now, as s many people report same issue I’m sure it’s fivem related (the change they did within the update).
I hope we will at least get the information what was changed and could cause that chain of events so we can try to fix it ourselves.

It’s been 24h since the update, many servers have same issue and I they are just waiting for the update to fix that. There is still no response from staff.


#12

Provide a repro, and maybe you’ll get a ‘staff response’ that has any meaning.

We can’t install every single resource you guys use, so it’s impossible to actually reproduce this issue internally whatsoever.

Since nothing was changed that should cause an issue like this, it’s likely something to do with an obscure resource.

Also, if anyone comes along with ‘just install these 150 ESX resources and it’ll happen’, they’ll promptly be shown the door as we aren’t going to install 150 resources by hand that all have additional setup requirements just to be able to reproduce some obscure issue, so it’s up to you to provide information that can be used to fix the issue. If this happens to be an automated script to set up this ESX suite, or a server dump, or whatever, it doesn’t matter, as long as it can reproducibly show the issue within 15-30 minutes.

As a quick fix, you can remove some JS-based client resources you may happen to be using, such as some ‘custom radio’ resource that seems to be popular in servers that install 500 resources.


#13

Issues added to repos of the resources as well:


All of the JS based resources seems working fine (I have a few)


#14

FIX - Update:



#15

“Confirmed resources which are breaking the esx_status/property:
[Release] [JS] Radio

Stopping js radio seems to have fixed this error for me, thx