Rockstar Editor Crash 'Lithium-West-December'

GTA V version? Current
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) https://gyazo.com/dfb8b67c5dc44ccf566ad1e79d6777d1
System specifications GTX 1060 and Core i5 6600k
What did you do to get this issue? Typed ‘leavesession’ into console. I tried again and the same crash happened when entering a R* editor clip to edit it.
What server did you get this issue on? Kent RPC
CitizenFX.log file CitizenFX.log (195.9 KB)
.dmp files/report IDs 5fcb456c-04e6-437a-a730-6ea25c9728ef.dmp (7.5 MB)

I have tried restarting FiveM and my PC. I have reinstalled the Cache file and folder I have reinstalled FiveM.

Multiple people seem to be getting this error on the server I play on, I don’t think it is server specific however.

1 Like

I am also receving this crash when launching Rockstar Editor.

This error just randomly crashes me, even when I don’t launch rockstar editor, this is really annoying and would love to see a fix.

CfxCrashDump_2019_08_15_18_29_20.zip (1.7 MB)

I am also receiving this error when trying to do anything in the Rockstar Editor.

The R* Editor is not a supported feature of FiveM at this point. That aside, it somehow ‘breaking’ might be used as a cue to rework it a little and allow using it without having to be connected-but-disconnected to a server, since this particular crash seems to be a game script invoking a native trying to get a network object while disconnected.

This is technically a regression though: for performance reasons C# scripts were moved to directly invoking natives, but that doesn’t include the __try/__catch SEH handler, which means C# scripts that invoke a crashing native will crash the entire game.

Prior to that change, this’d only have led to infinite console spam about native execution failing.

This occurs for me when I use a script that causes you to leave the session (normally to ensure you’re not using Rockstar Editor in an active session which naturally causes issues), but keeps all the contents loaded in (thus allowing you to use it in R* editor). It takes about 20-30 seconds for the crash to occur afterwards. There is nothing consistant in CitizenFX.log that would cause it.

So yes, what you’ve said above makes sense. This has suddenly started occuring for everyone on our server in the last couple of weeks.

Is there a work around at this point?