Replace cars aren't working whatsoever


#1

GTA V version? Latest
Up to date? Yes
Legit or Pirate copy? Legit
Steam/CD/Social Club? Steam
Windows version? 10 home
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) none
System specifications i5 4600 GT 705 8gb ddr3 (I think)
What did you do to get this issue? Attempt to spawn in a replace car
What server did you get this issue on? My own
CitizenFX.log file CitizenFX.log (90.0 KB)

.dmp files/report IDs FiveM didn’t crash
If an issue with starting:
GTA V folder screenshot
GTA V/update/x64/dlcpacks screenshot
Filepath to FiveM folder
FiveM client folder screenshot
Did you try to disable/uninstall your Anti-virus?

Also add what you already tried so far.

I tried deleting the cache folder, since I changed a car, and it didn’t update in game even after restarting the server and rejoining. I completely ignored the fact that I’m not meant to delete the game folder in cache, so I reinstalled FiveM, and the same issue still occured.

edit: After deleting the cache folder, no replace cars spawned, and in the F8 console, it said that it thought that the car was in the cache, but it wasn’t there. Is there any way to fix this?


#2

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:


#3

can you show us how you are adding these replacement cars? config file? screenshots of the resource in question folder structure.


#4

The Filepath:


The list of vehicle files (part of it):

Just a blank __resource.lua and no config files, appeared to be working fine on my other server. I’m thinking it could be a client-side issue, as it thinks they’re in the cache, when they’re not - my mistake - I deleted the cache folder. Anyway to reset it or etc?


#5

Have you tried doing a single replace by itself? On my server I just have each vehicle in its own folder inside its own sub category such as “resources>[custom cars]>bugatti” so i put each vehicle in its own folder with a blank resource.lua and a stream folder


#6

Simple fix, just go into your fivem folder again, remove the cache folder again, but this time, remember to delete caches.xml as well! the reason fivem thinks its in the cache but it isnt is because the cache index shows it as already downloaded.

you don’t have to delete the full cache folder though, just go into the cache folder and remove everything except the “game” folder. it’ll save you from redownloading the 1GB download when you first install fivem.


#7

Thanks - I did try that before, but I guess I must’ve done something wrong! My cars are spawning perfectly again now :tada: