[Release] MySQL Async Library - 3.0.8

dev
mysql
basemods

#588

no is not sir, thanks.


#589

I get BUFFER SHORTAGE with Mysql-async 3.0.8 but 3.0.7 works perfectly fine for my server. Anyone else with the same issue? I can give more details if anyone needs them.
EDIT: So it seems that that it was bad caches, I cleared the one for mysql-async and its working all good now.


#590

I have a problem when I use it for a while. The server hangs chat. The chat is not responding. Check that cmd can not print anything.


I will encounter problems when more than 10 players, but if I use 2.1.2, I do not experience a problem, but I have encountered a delayed mysql response.


#591

Same thing is happening on my server…

After a while we’re not able to write in chat, take service, eat, drink etc
There’s no error in server console or in F8 console


#592

Odd, how about providing specifics? Maybe finding out what is causing the hang?

It is not happening for me. I run a similar but different mysql implementation all day.


#593

I can’t find anything specific… There is no error at all in both console
I’ve tryed asking my player their logs too and there’s no problem

The server just seem to “crash” but stay online, nobody can join, eat, drink, chat etc


#594

You might want to try link the instructions in this one, given you run on windows.


#595

Yeah I saw it…
I can give it a try, but the problem is that we can’t run it for a long time since it will take disc space
But my server can be 40 hours online without any problem and the next day it will crash 3 times


#596

well you should only trace 30-60s, around the issue happening.


#597

Hey,

I’ve set up a new project with the mysql-async library installed. It loads perfectly fine and everything goes according to plan, until I make an sql call. When ever I do so, it will just close the FXServer window and not display any crash logs, not even in the mysql error logs.

My call looks like the following (just a test call, because I couldnt get any mysql calls working):

function isWhiteListed(identifier)
		MySQL.ready(function ()
		    MySQL.Sync.fetchScalar('SELECT @parameters', {
		        ['@parameters'] =  'string'
		    })
		end)
		
		--return player
		return nil
end

Any ideas @zr0iq ?


#598
MySQL.ready(function ()
  local p = MySQL.Sync.fetchScalar('SELECT @parameters', {
    ['@parameters'] =  'string'
  })
  print(p)
end)

returns string for me like it should.


#599

Just tested it, “kinda” works but still not.
All I saw in the command window, was it starting to type “st” (as a part of “string” I assume) before it closed the FXServer window.

UPDATE:
Just tested it without the function call, now it works fine and outputs string. Interesting…


#600

I got a person on the ESX discord that’s getting:

Error running system event handling function for resource esplugin_mysql: citizen:/scripting/lua/scheduler.lua:41: 
Failed to execute thread: citizen:/scripting/lua/scheduler.lua:655: 
No such export mysql_fetch_all in resource mysql-async

Which tends to be start order but m-a is starting well before esplugin_mysql and all resources are starting without issue:

start mapmanager
start chat
start spawnmanager
start sessionmanager
start fivem
start hardcap
start rconlog
start scoreboard
start playernames
start mysql-async
start essentialmode
set mysql_debug false
start esplugin_mysql
start es_admin2
start async
start es_extended
start esx_menu_default
start esx_menu_list
start esx_menu_dialog

Would this be likely due to a slow mysql response time? Is there something else that could be causing it?


#601

This might be a cache issue. I hope.


#602

Hello sir I am the guy who is having the issue to which Schwim is talking about. I did delete the cache and it did not fix the issue still.


#603

On which server version are you? Check

https://runtime.fivem.net/artifacts/fivem/build_server_windows/master/


#604

Pretty sure im on the latest I can update anyway and try


#605

Error: (node:18896) UnhandledPromiseRejectionWarning: TypeError: Cannot read property ‘3’ of null
at parseConnectingString (mysql-async.js:5049:30)
at global.on (mysql-async.js:5067:18)
at citizen:/scripting/v8/main.js:193:28
Error: (node:18896) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
Error: (node:18896) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Help please :slight_smile:


#606

You are not using the latest version. It would tell you, your connection string is wrong.


#607

set mysql_connection_string “mysql://root:@localhost/roleplay”