[Release] MySQL Async Library - 3.0.8

dev
mysql
basemods

#547

what do I use to do this part on
…/artifacts/run.cmd +exec server.cfg > output.txt


#548

In your start.bat or so.


#549

cd /d C:\FiveMServer\cfx-server-data
C:\FiveMServer\run.cmd +exec server.CFG +set sv_licenseKey [licensekey]
/artifacts/run.cmd +exec server.cfg > output.txt
Thats how I put it, it don’t work so I don’t know where to put it sorry man I’m not used to this


#550

Yes and now run it, there should be an output.txt file in your folder.


#551

No theirs not thats what I mean when I said it didn’t work


#552

I got one now and it was empty


#553

Delete your cache and try again.


#554

[ERROR] [MySQL] An error happens on MySQL for query “UPDATE users SET bank=131
6999,money=215019 WHERE identifier=@identifier {identifier=steam:11000010dc7
xxxx}”: Couldn’t connect to server


System.Reflection.TargetInvocationException: Exception has been thrown by the t
rget of an invocation. —> System.ArgumentOutOfRangeException: Index was out o
range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgum
nt argument, System.ExceptionResource resource) [0x00029] in <0123fd5b1a1040fe9
70a7e0d4b28acb>:0
at System.ThrowHelper.ThrowArgumentOutOfRangeException () [0x00000] in <0123f
5b1a1040fe9d70a7e0d4b28acb>:0
at System.Collections.Generic.List`1[T].get_Item (System.Int32 index) [0x0000
] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.Com
ilerServices.Closure,System.Runtime.CompilerServices.CallSite,object,int)
at CitizenFX.Core.MsgPackDeserializer+<>c__DisplayClass36_1.b__1 (System.Object res, System.Object err) [0x00246] in C:\gl\bui
ds\4ff63adb\0\cfx\fivem\code\client\clrcore\MsgPackDeserializer.cs:290
at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (S
stem.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.
indingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parame
ers, System.Globalization.CultureInfo culture) [0x00032] in <0123fd5b1a1040fe9d
0a7e0d4b28acb>:0
— End of inner exception stack trace —

Server stack trace:
at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.
indingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parame
ers, System.Globalization.CultureInfo culture) [0x00048] in <0123fd5b1a1040fe9d
0a7e0d4b28acb>:0
at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] pa
ameters) [0x00000] in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000e7] in <012
fd5b1a1040fe9d70a7e0d4b28acb>:0
at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00008
in <0123fd5b1a1040fe9d70a7e0d4b28acb>:0
at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <0123fd5
1a1040fe9d70a7e0d4b28acb>:0
at CitizenFX.Core.FunctionReference.Invoke (System.Int32 reference, System.By
e[] arguments) [0x00062] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrco
e\FunctionReference.cs:65
at CitizenFX.Core.InternalManager.CallRef (System.Int32 refIndex, System.Byte
] argsSerialized, System.IntPtr& retvalSerialized, System.Int32& retvalSize) [0
00000] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\client\clrcore\InternalManager
cs:249
at (wrapper remoting-invoke-with-check) CitizenFX.Core.InternalManager:CallRe
(int,byte[],intptr&,int&)
at (wrapper xdomain-dispatch) CitizenFX.Core.InternalManager:CallRef (object,
yte[]&,byte[]&,int,byte[],int&)

Exception rethrown at [0]:
at (wrapper xdomain-invoke) CitizenFX.Core.InternalManager:CallRef (int,byte[
,intptr&,int&)
at (wrapper remoting-invoke-with-check) CitizenFX.Core.InternalManager:CallRe
(int,byte[],intptr&,int&)
at CitizenFX.Core.MonoScriptRuntime.CallRef (System.Int32 refIndex, System.By
e[] argsSerialized, System.Int32 argsSize, System.IntPtr& retvalSerialized, Sys
em.Int32& retvalSize) [0x00013] in C:\gl\builds\4ff63adb\0\cfx\fivem\code\clien
\clrcore\MonoScriptRuntime.cs:151
Error resuming coroutine: citizen:/scripting/lua/MessagePack.lua:830: missing b
tes
stack traceback:
[C]: in function ‘error’
citizen:/scripting/lua/MessagePack.lua:830: in method ‘underflow’
citizen:/scripting/lua/MessagePack.lua:465: in field ‘any’
citizen:/scripting/lua/MessagePack.lua:860: in field ‘unpack’
citizen:/scripting/lua/scheduler.lua:602: in field ‘cb’
citizen:/scripting/lua/scheduler.lua:373: in function <citizen:/scripti
g/lua/scheduler.lua:363>


#555

INFO: No channel links found in configuration file.
Found new resource carhud in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//carhud
Found new resource commands in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//commands
Found new resource customchat in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//customchat
Found new resource deathmessages in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//deathmessages
Found new resource deleteveh in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//deleteveh
Found new resource fivem in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//fivem
Found new resource fivem-awesome1501 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//fivem-awesome1501
Found new resource fivem-map-hipster in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//fivem-map-hipster
Found new resource fivem-map-skater in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//fivem-map-skater
Found new resource frfuel in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//frfuel
Resolved live-internal.fivem.net:30110 to 178.32.9.100:30110
Found new resource handsup in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//handsup
Found new resource hat in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//hat
Found new resource hazards in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//hazards
Found new resource lscustoms in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//lscustoms
Found new resource lux_vehcontrol in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//lux_vehcontrol
Found new resource map in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//map
Found new resource ooc in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//ooc
Found new resource pointing in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//pointing
Found new resource removeAIcops in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//removeAIcops
Found new resource runcode in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//runcode
Found new resource StreetDisplay in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//StreetDisplay
Found new resource vMenu in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//vMenu
Found new resource welcome in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//welcome
Found new resource wk_vehdamage in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//wk_vehdamage
Found new resource esplugin_mysql in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/esplugin_mysql
Found new resource essentialmode in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/essentialmode
Found new resource es_admin2 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/es_admin2
Found new resource es_extended in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/es_extended
Found new resource mysql-async in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/mysql-async
Found new resource race in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gamemodes]/race
Found new resource race-test in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gamemodes]/race-test
Found new resource channelfeed in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gameplay]/channelfeed
Found new resource irc in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gameplay]/irc
Found new resource obituary in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gameplay]/obituary
Found new resource obituary-deaths in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[gameplay]/obituary-deaths
Found new resource fivem-loading-sleek in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[loading screen]/fivem-loading-sleek
Found new resource mapmanager in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[managers]/mapmanager
Found new resource baseevents in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/baseevents
Found new resource chat in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/chat
Found new resource hardcap in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/hardcap
Found new resource rconlog in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/rconlog
Found new resource scoreboard in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/scoreboard
Found new resource sessionmanager in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/sessionmanager
Found new resource spawnmanager in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[system]/spawnmanager
Found new resource betaguns in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[test]/betaguns
Found new resource gameInit in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[test]/gameInit
Found new resource keks in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[test]/keks
Found new resource esx_menu_default in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/[ui]/esx_menu_default
Found new resource esx_menu_dialog in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/[ui]/esx_menu_dialog
Found new resource esx_menu_list in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[esx]/[ui]/esx_menu_list
Found new resource addonr35 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/addonr35
Found new resource buffalo2 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/buffalo2
Found new resource comet2 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/comet2
Found new resource dominator in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/dominator
Found new resource ferrari in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/ferrari
Found new resource r5 in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/r5
Found new resource subaru in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/subaru
Found new resource vacca in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Civ]/vacca
Found new resource Captain14_FBI in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Police]/[Detective]/Captain14_FBI
Found new resource Captain14_LSPD in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Police]/[LSPD]/Captain14_LSPD
Found new resource Captain14_Sheriff in C:/Users\Autry\Desktop\FiveMServer\cfx-server-data/resources//[Single Cars]/[Police]/[SSDP]/Captain14_Sheriff
Started resource sessionmanager
Started resource mapmanager
Started resource spawnmanager
Started gametype Freeroam
Started resource fivem
Started resource rconlog
Started resource scoreboard
Error loading script mysql-async.js in resource TODO: TypeError: global.exports is not a function
stack:
TypeError: global.exports is not a function
at Object. (mysql-async.js:4979:8)
at webpack_require (mysql-async.js:20:30)
at mysql-async.js:84:18
at mysql-async.js:87:10
Failed to load script mysql-async.js.
Started resource mysql-async
Started resource essentialmode
Started resource esplugin_mysql
Started resource es_admin2
Could not find dependency async for resource es_extended.
^3Couldn’t start resource es_extended.^7
Started resource esx_menu_list
Started resource esx_menu_dialog
Could not find dependency async for resource es_extended.
Could not start dependency es_extended for resource esx_menu_default.
^3Couldn’t start resource esx_menu_default.^7
Loaded vMenuShared.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_1443018752
Loaded vMenuServer.net, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null into ScriptDomain_1443018752
Instantiated instance of script GHMatti.Http.RequestInternal.
Instantiated instance of script GHMatti.Http.Request.
Instantiated instance of script vMenuServer.BanManager.
Loaded Newtonsoft.Json, Version=11.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed into ScriptDomain_1443018752
Instantiated instance of script vMenuServer.MainServer.
Instantiated instance of script vMenuServer.UpdateChecker.
Started resource vMenu
Started resource map
Started resource Captain14_FBI
Started resource Captain14_LSPD
Started resource Captain14_Sheriff
Started resource fivem-loading-sleek
Started resource lux_vehcontrol
Started resource carhud
Started resource handsup
Started resource wk_vehdamage
Started resource StreetDisplay
Started resource deleteveh
Started resource addonr35
Started resource comet2
Started resource dominator
Started resource ferrari
Started resource r5
Started resource vacca
Started resource deathmessages
Started resource subaru
Started resource buffalo2
Started resource frfuel
Started resource lscustoms
Started resource pointing
Started resource customchat
Started resource removeAIcops
Started resource ooc
Started resource commands
Started resource welcome
Started resource hat
Could not open myLogo.png for reading.
Listening on socket failed - libuv error address already in use.
net-tcp-server failed to create server: couldn’t listenCould not bind MultiplexTcpServer to 0.0.0.0:30120.
Could not bind on 0.0.0.0:30120 - is this address valid and not already in use?
Could not find dependency async for resource es_extended.
^3Couldn’t start resource es_extended.^7
Could not find dependency async for resource es_extended.
Could not start dependency es_extended for resource esx_menu_default.
^3Couldn’t start resource esx_menu_default.^7
Could not open myLogo.png for reading.
Authenticating server license key…
Server license key authentication succeeded. Welcome!
cfx> Sending heartbeat to live-internal.fivem.net:30110

Current version: 5.0.3
Updater version: 5.0.3

Everything is fine!

Started map fivem-map-skater
Started resource fivem-map-skater
hitch warning: frame time of 1688 milliseconds

I finally got it but this is all I got hope it helps you guys fix what ever is going on


#556

You guys do not like reading do you? Literally 2 posts before yours is a solution to this weird issue.

Delete the server cache and it works.

Also the third time, I posted this in this topic.


#557

You literally can’t tell me that is the fix, I’ve done that plenty of damn times my cache gets reset atleast 4-5 times alone just in developing this server so don’t tell me that is my fix cause it for sure is not so don’t say I don’t like reading or shit dude. Just cause it works for some People don’t mean it works for everyone


#558

I do not know how you delete your cache, but I do it like this if needed:

image
Deleting that folder by hand.

Stop being a rude dick. I cannot fix issues I do not have, provide something reproducable for people you want to help. Otherwise nobody can help you.


#559

You started being a dick by saying I don’t like to read, simple as that, if you don’t know I did that then don’t be saying it over an over soundin like a broken record cause I delete my cache with everything I do small or big, deleted at leave 5 times a day


#560

Oh and you feel like giving me some issue, and saying it does not work can help anyone, help you?

Accusing people does neither help you or me. How about you start and tell me what causes the issue. If I cannot reproduce it, I cannot fix it. All I can say like you is “I have an issue / I have no issue”.


#561

I don’t know what causes the issue just know I set up database and went to run server and got this

Error loading script mysql-async.js in resource TODO: TypeError: global.exports is not a function
stack:

TypeError: global.exports is not a function

at Object. (mysql-async.js:4979:8)

at webpack_require (mysql-async.js:20:30)

at mysql-async.js:84:18

at mysql-async.js:87:10

Failed to load script mysql-async.js.

I’ve tried re doing database multiple times, cleared cached a lot, re installed the latest artifact even re installed fivem

This is what I put in my cfg about all the starts for the database
set es_enableCustomData 1
set mysql_connection_string “server=127.0.0.1;database=essentialmode;userid=root;password=password”


#562

which server version are you using?

https://runtime.fivem.net/artifacts/fivem/build_server_windows/master/

update to the latest (819), delete cache and try again. :slight_smile:

for me the issue only came up after a server update. Maybe it is an old version or a revoked one. Or at least I hope it is.


#563

Hi Guys. I’ve been getting these Hitch frame warnings in my serverPrzechwytywanie
Do you know how to solve this problem?


#564

I see two new ones ones so I’ll see if it fixes when I get home, an @revolt1 only fix I’ve found my self is my internst was two slow but your could be different problem mine comes in once an a while


#565

I created a new empty database and the problem continues to appear


#566

It shouldn’t be a database error, every time I have this even when joining other servers its always been my internet connection, once I upgraded that it went away, but still get it periodically, but I don’t know what internet you have, but is it just MySql or is it more resources that’s pop up? @revolt1