[Release] MySQL Async Library - 3.0.8

dev
mysql
basemods

#467

this happens in the packet parser. Which db version were you using?

and it would be nice to know on which query.


#468

Still using Mysql Version : 5.7.23

And the query is done on that part of the code, it doesn’t tell me which line tho.
I just know it’s when it try to get the daily or montly record


#469

Update to 3.0.5

  • DateTime, DateTime2, Timestamp, Timestamp2, Date, Year should now behave properly. Is cast to ms, not to seconds.
  • Time, Time2 are currently not parsed.
  • It should be STABLE now on Linux without any leakage.
    Many thanks to @Doacola for running tests showing stable ram.

#470

Someone can help me because after I updated the script is looking like this error for me on the console and my gcphone is no longer sending sms and every time I give that same error.


#471

sms and arrived, but only after I rebooted the server, could someone help me in this problem please


#472

I made the same way as the explanation, above and worked for the messages plus the error continues in the console, but I noticed that the error give every time a player enters the server


#473

run it please with set mysql_debug 1 see on which query the packet error appears.

tell me your database version (mysql / mariadb) and the actual version.

send me the schema of the table you are querying.

then I can actually try and start fixing it. As “i got an error” does very often not help.


#474

le passing here what I found with set mysql_debug 1


#475

using Mariadb 10.1.36 from Xampp, because Maria.DB does not even pick up this josa


#476

I am not seeing the error pop up yet. in your screenshots.


#477

And when I call, I’ll hit some more prints here for you.


#478

You can start the server via powershell and use tee for a log.


#479


#480

it is the owned_properties/properties call. May you link me a github repository for it? it is a total mess.

Also it is many queries in one, which does not seem to work anymore.


#481

#482

I’m using this latest version available


#483

I am not seeing the query in there. It is this one.

SET @ownedProperties = (SELECT...); SET @gateways = (SELECT gateway...); SELECT name FROM properties WHERE name = ownedProperties AND gateway = @gateways OR name = @gateways AND gateway IS NULL or name = @ownedProperties and gateway IS NULL;

I wanted to do a PR on that resource.


#484

do not have that query, no, I’ve tried it from top to bottom and I did not find it zr0iq


#485

just know to tell me where to add this query zr0iq because it does not have there


#486

This is the query that results in an error, I do not know which resource it is from. So I cannot give you a solution, you would need to find it yourself.

Then I can help you.