[Release] MDT & Character & Vehicle Reg System & Licenses - Fully Ingame [1.2]


#48

Cleaned up the topic, user (daddylongneck) has been suspended for continuous misbehavior.


#49

Could you perhaps make a config option to keep registered vehicles? It will be kind of annoying to re-register all of the player’s vehicles every time they join the server. If a config option isn’t viable, could you point out the place in the files where I can disable this function?

EDIT: Found it. MDT/mdt_server.lua:449


#50

UPDATE 1.2

  • Added /flashid to flash your id (25 meters)
  • Now you can take licenses! Blips and driving test and indutruction / tutorial! Licenses for CDL, DMV and Firearm (Pilot still in dev) Still in early development and everything in that part isnt perfect yet so there after you can completly turn off this feature in the config.
  • Added more config options
  • Fixed warrant issue when warrant wasent always added
  • Added blip/function for resetting your license points
  • Police can now give points /mdt addp ID POINTS
  • Vehicle registration bug has been patched
  • Added event if you wanna clear someones warrants from another script via “TriggerServerEvent(‘SRR:RemoveFromWarrentList’, GetPlayerServerId(PlayerId()))”
  • New SQL import file so now you can edit tables and remove lines etc

Link: https://github.com/Clatanii/MDT-CHAR

Continue to report issues and bugs to me so i can patch and fix them! Thank you for the amazing support lately!


#51

This is a great MDT… Question… The /flashid shows for the player but the police can’t see it in the chat. Is the a fix for this?


#52

Hey I’m pretty sure you have server called SRRP? Like I seen ur post n I wonder if u can get job command here


#53

Can you use it with ESX?


#54

Hello there, Thank you! Hmm are you using any frameworks? This is only showing to people 25 meters away shouldnt effect if its a police or not.


#55

@Caden23 Hey Yeah i used to have a server called SRR before some people fucked me over, Anyways im working on a job system that may get released in a while.

@Ciffez it should work fine to have it with ESX, However it isnt working “with” ESX character system or anything, Its a standalone.


#56

Ah ok hey so I use new update but I try make license off in config and it no work and I turn to false because I like the license but I think people will not do it so could u any chance make a update so I can use like old version but without license folder


#57

Sorry I’m a little slow on the uptake here, so when you say drop the “dropme.sql” file in your database, where/what is that exactly? Do I drop it in my mysql-async folder?


#58

when i click run sql file i get this error
SQL Error (1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '–ALTER TABLE srr_char_bolos --ADD PRIMARY KEY (ID);---- Index för ’ at line 14

any ideas on a fix?


#59

Updated the SQL import file, Try now.


#60

Hi there, All good, drag that to your desktop or something then go into your database and click “import” and then choose the file and go.


#61

when police do a mdt vehicle check comes back no person found on plate


#62

You might need the updated SQL file, Have you tried that one?


#63

i have tried one from yesterday


#64

I updated one right now as it seems like people had trouble with it, Try that one and see if it works correctly


#65

i will try now


#66

http://prntscr.com/m7kocg still broken


#67

Okay, I think its something on your end as it worked for me. Take this to DM’s so we dont spam the topic :stuck_out_tongue: