[Release] LiveMap


#440

Do i have to implement the stuff for the blips into my script because players are not shown on the map.

Got the same issue as @DaveThrave

And yes i properly changed everything in the config.


#441

Hey, I tried installing it but I am getting these errors. Does someone know how to fix this? I install the latest version but didn’t fix.

Sincerely- Michon


#442

You may changes the Version.json file. go to Version.json and set the version to 2.2.11


#443

Thanks for responding this quickly but unfortunately that version was already imputed into the versoin.json file
and I got another error now " Error getting blips! blip cache is empty"


#444

Go into you’re server and type /blips generate


#445

Awesome that worked but now it doesn’t show player blips and it doesn’t want to connect to my server for some reason.


#446

Same as my issue, i dont know how to fix it. @Havoc Hey, there is a lot of people having this issue, even when we have the correct details in the Config. Can you send us a older version or something?


#447

Does no-one have a new Google API key bypass so that the error of “http://prntscr.com/m2psuw” can stop.


#448

As far as I can see it’s maybe 3 people having this “issue”. Have you all checked your firewall rules, port forwarding rules if they were needed? Have you all made sure you’ve definitely changed the IPs to the FiveM server’s public IP? Are you serving the web interface over HTTP and not HTTPS?

All the versions are on the git. Use one of them if you need. I don’t get why you would though. There’s been nothing done that would mess with the socket connection.

Afaik there is no known bypass. As far as I can tell though it only affects the ability to switch to the different map images. This can be easily done by switching the API used to display the map images but, the rewrite I’m currently working on is a bit more complicated than I first thought.


#449

Do we actually need to enable more ports? If yes what port do you want me to open? (( It reacts, it created the blips actually. but dont know what the issue is.)


#450

Guys, I got mine to work by putting localhost as the IP address, I’m using a VDS so your mileage may vary.


#451

I use your mod, I like it very much!

Seid Today I have a weird bug.
Initially, other foreign players were displayed on the LiveMap.
For a few hours no more are displayed by my server and only foreign players.

This I have then checked the server IP again and the settings.
Nothing was changed and everything fits so far …

What can that be?


#452

The port you set for the Websocket. 30121 is the default.

This won’t work for people using the interface outside of your server as it’s client side and not server side (I plan on removing the PHP as this seems to be confusing people).

I am very sorry but I have no idea what you’re trying to say.


#453

What does it mean if it says can’t load blips, blips cache is empty? I try to do /blips generate and in console it says blips empty, no need to save. Player blips are showing fine.

Also I noticed that you cannot have your site behind https. It will not work. Not a big deal to me as I just disabled it for the maps folder, but for other people this may be their issue.


#454

Sorry my english xd

A few days ago the LiveMap went perfectly!

Yesterday, although I have not changed anything, he shows other players who are not on my server.

And today he does not even show the players who are on my server …

But the blips go -.-


#455

Ok so ports forwarded to 30121 on my windows server 2012 box from my router and exceptions created for both TCP and UDP in/out… in Windows firewall tested ports are fine I have set

set socket_port 30121
set livemap_debug 0
set blip_file “server/blips.json”
set livemap_access_control “*”

in my server.cfg

I have the live map interface on my 1and1 hosting and can see it loaded fine, but the disconnected always shows, and im getting LiveMap coulndt save the bips to file… maybe the directory isnt writable?

Any help would be much appreciated.


#456

@Havoc are the coordinates on the web interface the same as ingame?


#457

No, but there is a function to convert GTA5 Coords to the Google Map Coords.


#458

@Havoc I’m trying to troubleshoot what can cause Live Map to just stop updating? When it does it I have to restart the server resource - there are no errors. I have generally around 20-25 players and 2-3 people accessing the live map page.

Is there anything I can do to debug what is going on that stops everything updating? The live map shows it online but the markers stop moving. It’s like the socket is open but the data loop isn’t updating? Fixed by restarting the resource on the server and then refreshing map page.


#459

Live map is a great script | addon for server as it brings a little bit more rp to the server you are playing on or a part on I have to say I would recamend you download this and a big thank you to @Havoc for making this