[Release] LiveMap


#296

So I ran the command /blips generate and my terminal shows that I am generating blips. Additionally, the map webpage I have show those blips on the map, but I am not getting any player blips. Am I missing something? Or should I be running a command somewhere to generate player blips?

Thanks In advance for any assistance.


#297

Hello, I wanted to know is their away to make the map only show Emergency Vehicles and players who are Emergency Personal instead of all active players.


#298

ive done all the steps listed to try to get this to work but it wont show the blips. i keep getting an error generating blips.


#299

We are having issues with the LiveMap not connecting to our servers. No error. Just wont connect… https://gyazo.com/9aa76568071b285d62f6109517a855ca

all the Ports are correct and same

Server IP is correct
Was working yesterday and now it won’t


#300

I’m not seeing a blips.json file anywhere…


#301

you have to do it ingame /blips generate

it will work if you have:
server.cfg:

set socket_port 30121 # must be a port that isn't used
set livemap_debug 0 # i don't worry about that
set blip_file "server/blips.json" # this is where the blips file is stored
set livemap_access_control "*" # these are permissions Example: a user with admin ace perms can do /blips generate normal users cannot

#302

also @Havoc it won’t connect to the server. everything is there it’s all the right ports everything is set in server.cfg the blips work but it won’t connect at all any idea? and it’s non ssl (HTTP)


#303

i do not have a server.php in the config folder and for some reason it only loads a black screen.


#304

I can’t get the interface to work. When I connect with localhost/livemap I only get a white screen. When I connect with http://localhost:30120/livemap it just says route /livemap not found. I did the blip command in game and now I can see all the blip coordinates from http://localhost:30120/live_map/blips.json. I have also set livemap_debug to 2, but no errors are popping up, but I can see when I move. I have port forwarded. I have tried setting both IP’s in the config (The one on the webserver) to localhost and my public IP, to no luck. I don’t really know the correct way to set up that, but I need help to get the interface to work.


#305

I got the blips to work, thanks @rhys19 However, plays still don’t show up.


#306

yeah that’s the issue i’m having :frowning:


#307


well weird it works on my localhost!
but not from a web host


#308

All you need now is to install maps but it should work from web if your webserver is live


#309

it is live it just won’t connect to the server itself


#310

Make sure you’re putting your FiveM’s public IP in the config files. And that it’s allowed through the firewall, if needed.


#311

i’ve put my public fivem ip in the cfg and the vps doesn’t say it has any firewall enabled but i’ll check real quick i’m hosting it on https://emperorhosting.com/
that might be the issue i’ve used vps nginx i will try that next.


#313

ok actually how would i set up a reverse proxy so i can keep my https (i’m using apache2)


#314

What webhost are you using? Hostinger? I think I know the issue give me a few minutes to test though.


#315

i wanted a reverse proxy on my ubuntu vps with nginx if someone can let me know then i will go back to using my ssl but my Hosting Provider was Emperor Hosting i’d like that to be fixed and it doesn’t even have an ssl setup so i’d like to know why thanks!


#316

93d9e63ebc21ce5ddaa26d06445fed4c

you think that has anything to do with it?

Server.cfg

# LIVE MAP DO NOT TOUCH #

set socket_port 3085
set livemap_debug 2
set blip_file "server/blips.json"
set livemap_access_control "*"
start live_map


# LIVE MAP END #

and the config.php is set to my servers ip address,socket port,and the resource name i don’t get it if it works on my localhost but not on my ubuntu vps with nginx non ssl

and yes the fivem server is running.